1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 03:26:48 +03:00
openwrt-xburst/target/linux/adm5120-2.6/patches/500-Nand.patch
florian 54a10cd626 Move NAND driver from rb1xx to adm5120, rbmipsnand fixed by David Goodenough, thanks !
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6991 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-04-17 22:15:50 +00:00

30 lines
936 B
Diff

diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
index cfe288a..c528024 100644
--- a/drivers/mtd/nand/Kconfig
+++ b/drivers/mtd/nand/Kconfig
@@ -55,6 +55,12 @@ config MTD_NAND_TOTO
help
Support for NAND flash on Texas Instruments Toto platform.
+config MTD_NAND_RB100
+ tristate "NAND Flash device on RB100 board"
+ depends on MTD_NAND
+ help
+ Support for NAND flash on RB100 platform.
+
config MTD_NAND_IDS
tristate
diff --git a/drivers/mtd/nand/Makefile b/drivers/mtd/nand/Makefile
index 4174202..2be57c1 100644
--- a/drivers/mtd/nand/Makefile
+++ b/drivers/mtd/nand/Makefile
@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_NAND_IDS) += nand_ids.
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
obj-$(CONFIG_MTD_NAND_TOTO) += toto.o
+obj-$(CONFIG_MTD_NAND_RB100) += rbmipsnand.o
obj-$(CONFIG_MTD_NAND_AUTCPU12) += autcpu12.o
obj-$(CONFIG_MTD_NAND_EDB7312) += edb7312.o
obj-$(CONFIG_MTD_NAND_AU1550) += au1550nd.o