mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 05:21:54 +02:00
02e216b7f2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11197 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
994 B
Diff
25 lines
994 B
Diff
Index: linux-2.6.23.17/drivers/mtd/devices/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.23.17.orig/drivers/mtd/devices/Kconfig
|
|
+++ linux-2.6.23.17/drivers/mtd/devices/Kconfig
|
|
@@ -76,6 +76,10 @@ config MTD_M25P80
|
|
used for program and data storage. Set up your spi devices
|
|
with the right board-specific platform data.
|
|
|
|
+config MTD_SPIFLASH
|
|
+ tristate "Atheros AR2315/6/7 SPI Flash support"
|
|
+ depends on ATHEROS_AR5315
|
|
+
|
|
config MTD_SLRAM
|
|
tristate "Uncached system RAM"
|
|
help
|
|
Index: linux-2.6.23.17/drivers/mtd/devices/Makefile
|
|
===================================================================
|
|
--- linux-2.6.23.17.orig/drivers/mtd/devices/Makefile
|
|
+++ linux-2.6.23.17/drivers/mtd/devices/Makefile
|
|
@@ -18,3 +18,4 @@ obj-$(CONFIG_MTD_BLOCK2MTD) += block2mtd
|
|
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
|
|
obj-$(CONFIG_MTD_DATAFLASH26) += at91_dataflash26.o
|
|
obj-$(CONFIG_MTD_M25P80) += m25p80.o
|
|
+obj-$(CONFIG_MTD_SPIFLASH) += spiflash.o
|