mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-02 01:30:16 +02:00
c5552ad039
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21952 3c298f89-4303-0410-b956-a3cf2f4a3e73
24 lines
771 B
Diff
24 lines
771 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -111,6 +111,10 @@ config IP175C_PHY
|
|
tristate "Driver for IC+ IP175C/IP178C switches"
|
|
select SWCONFIG
|
|
|
|
+config AR8216_PHY
|
|
+ tristate "Driver for Atheros AR8216 switches"
|
|
+ select SWCONFIG
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_IP175C_PHY) += ip175c.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|