1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-18 19:57:09 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.23/310-adm5120_wdt.patch
juhosg 4bb1a03501 [adm5120] add watchdog driver
Here is the driver for the hardware watchdog timer
in ADM5120 SoC. Patch is against current svn Kamikaze.

Here is only kernel driver. To activate watchdog you have
to use some userspace software writing to watchdog
device. I think there is one in busybox.

Signed-off-by: Ondrej Zajicek <santiago@crfreenet.org>


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9961 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-12-27 14:40:03 +00:00

34 lines
1.3 KiB
Diff

diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Kconfig linux-2.6.23.11/drivers/char/watchdog/Kconfig
--- linux-2.6.23.11-old/drivers/char/watchdog/Kconfig 2007-12-15 04:50:05.000000000 +0100
+++ linux-2.6.23.11/drivers/char/watchdog/Kconfig 2007-12-26 20:17:56.000000000 +0100
@@ -583,6 +583,18 @@
# MIPS Architecture
+config ADM5120_WDT
+ tristate "Infineon ADM5120 SoC hardware watchdog"
+ depends on WATCHDOG && MIPS_ADM5120
+ help
+ This is a driver for hardware watchdog integrated in Infineon
+ ADM5120 SoC. This watchdog simply watches your kernel to make sure
+ it doesn't freeze, and if it does, it reboots your computer after a
+ certain amount of time.
+
+ To compile this driver as a module, choose M here: the module will be
+ called adm5120_wdt.
+
config INDYDOG
tristate "Indy/I2 Hardware Watchdog"
depends on SGI_IP22
diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Makefile linux-2.6.23.11/drivers/char/watchdog/Makefile
--- linux-2.6.23.11-old/drivers/char/watchdog/Makefile 2007-12-15 04:50:05.000000000 +0100
+++ linux-2.6.23.11/drivers/char/watchdog/Makefile 2007-12-26 20:19:24.000000000 +0100
@@ -87,6 +87,7 @@
# M68KNOMMU Architecture
# MIPS Architecture
+obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
obj-$(CONFIG_INDYDOG) += indydog.o
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o