mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 23:11:51 +02:00
d8db515de0
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30346 3c298f89-4303-0410-b956-a3cf2f4a3e73
29 lines
739 B
Diff
29 lines
739 B
Diff
--- a/drivers/net/wireless/ath/Makefile
|
|
+++ b/drivers/net/wireless/ath/Makefile
|
|
@@ -8,7 +8,7 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
|
|
ath-objs := main.o \
|
|
regd.o \
|
|
hw.o \
|
|
- key.o
|
|
+ key.o \
|
|
+ debug.o
|
|
|
|
-ath-$(CONFIG_ATH_DEBUG) += debug.o
|
|
ccflags-y += -D__CHECK_ENDIAN__
|
|
--- a/drivers/net/wireless/ath/ath.h
|
|
+++ b/drivers/net/wireless/ath/ath.h
|
|
@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
|
|
#endif /* CONFIG_ATH_DEBUG */
|
|
|
|
/** Returns string describing opmode, or NULL if unknown mode. */
|
|
-#ifdef CONFIG_ATH_DEBUG
|
|
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
|
|
-#else
|
|
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
|
|
-{
|
|
- return "UNKNOWN";
|
|
-}
|
|
-#endif
|
|
|
|
#endif /* ATH_H */
|