mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-04 20:25:20 +02:00
a826f98491
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15561 3c298f89-4303-0410-b956-a3cf2f4a3e73
25 lines
800 B
Diff
25 lines
800 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -100,6 +100,11 @@ config AR8216_PHY
|
|
tristate "Driver for Atheros AR8216 switches"
|
|
select SWCONFIG
|
|
|
|
+config MICREL_PHY
|
|
+ tristate "Drivers for Micrel/Kendin PHYs"
|
|
+ ---help---
|
|
+ Currently has a driver for the KSZ8041
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
|
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
|
|
+obj-$(CONFIG_MICREL) += micrel.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|
|
obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o
|