1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 04:09:23 +03:00
openwrt-xburst/package/vnc-reflector/patches/01-honor_include_lib_path.patch
nico c56be3f994 add an Id tag to the Makefile, set md5sum,
don't use PKG_INSTALL_DIR since upstream does not provide a make install target


git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2667 3c298f89-4303-0410-b956-a3cf2f4a3e73
2005-12-14 00:39:11 +00:00

26 lines
670 B
Diff

--- vnc_reflector/Makefile.orig 2005-12-14 01:25:53.000000000 +0100
+++ vnc_reflector/Makefile 2005-12-14 01:28:05.000000000 +0100
@@ -14,10 +14,11 @@
#
# Variables you might want to edit: CFLAGS, CONFFLAGS
-IFLAGS = -I.
+IFLAGS = -I. -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+OFLAGS = -O2
# Production
-CFLAGS = -O2 $(IFLAGS)
+CFLAGS = $(OFLAGS) $(IFLAGS)
# Debug (strict)
#CFLAGS = -g -pedantic -Wall $(IFLAGS)
# Debug (profiling)
@@ -29,7 +30,7 @@
CONFFLAGS = -DUSE_POLL
# Link with zlib and JPEG libraries
-LDFLAGS = -L/usr/local/lib -lz -ljpeg
+LDFLAGS = -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lz -ljpeg
PROG = vncreflector