1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 08:31:31 +03:00
openwrt-xburst/target/linux/rb532/patches-2.6.24/510-rb500_led.patch
florian 82da4199c3 Add basic 2.6.24 support for rb532, korina napi code has to be adapted to work
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11844 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-07-15 17:18:28 +00:00

28 lines
1.1 KiB
Diff

diff -urN linux-2.6.24.7/drivers/leds/Kconfig linux-2.6.24.7.new/drivers/leds/Kconfig
--- linux-2.6.24.7/drivers/leds/Kconfig 2008-07-15 15:27:55.000000000 +0200
+++ linux-2.6.24.7.new/drivers/leds/Kconfig 2008-07-15 15:35:24.000000000 +0200
@@ -120,6 +120,12 @@
help
This option enables support for the CM-X270 LEDs.
+config LEDS_RB500
+ tristate "LED Support for RB5xx boards"
+ depends on LEDS_CLASS && MIKROTIK_RB500
+ help
+ This option enables support for the yellow user LED on RB5xx boards.
+
comment "LED Triggers"
config LEDS_TRIGGERS
diff -urN linux-2.6.24.7/drivers/leds/Makefile linux-2.6.24.7.new/drivers/leds/Makefile
--- linux-2.6.24.7/drivers/leds/Makefile 2008-07-15 15:27:55.000000000 +0200
+++ linux-2.6.24.7.new/drivers/leds/Makefile 2008-07-15 15:35:38.000000000 +0200
@@ -20,6 +20,7 @@
obj-$(CONFIG_LEDS_COBALT_RAQ) += leds-cobalt-raq.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
obj-$(CONFIG_LEDS_CM_X270) += leds-cm-x270.o
+obj-$(CONFIG_LEDS_RB500) += leds-rb500.o
# LED Triggers
obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o