1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 02:07:37 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.23/620-phy_adm6996.patch
juhosg f0c66715de [kernel] refresh generic 2.6.23 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11187 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-18 20:24:51 +00:00

27 lines
968 B
Diff

Index: linux-2.6.23.17/drivers/net/phy/Kconfig
===================================================================
--- linux-2.6.23.17.orig/drivers/net/phy/Kconfig
+++ linux-2.6.23.17/drivers/net/phy/Kconfig
@@ -60,6 +60,11 @@ config ICPLUS_PHY
---help---
Currently supports the IP175C PHY.
+config ADM6996_PHY
+ tristate "Driver for ADM6996 switches"
+ ---help---
+ Currently supports the ADM6996F switch
+
config FIXED_PHY
tristate "Drivers for PHY emulation on fixed speed/link"
---help---
Index: linux-2.6.23.17/drivers/net/phy/Makefile
===================================================================
--- linux-2.6.23.17.orig/drivers/net/phy/Makefile
+++ linux-2.6.23.17/drivers/net/phy/Makefile
@@ -12,4 +12,5 @@ obj-$(CONFIG_SMSC_PHY) += smsc.o
obj-$(CONFIG_VITESSE_PHY) += vitesse.o
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_FIXED_PHY) += fixed.o