1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-23 16:20:43 +03:00
openwrt-xburst/target/linux/adm5120-2.6/patches/007-adm5120_pci.patch
juhosg 8b2c7d0c93 [adm5120] update to 2.6.22-rc6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7758 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-06-28 16:08:28 +00:00

24 lines
1006 B
Diff

Index: linux-2.6.22-rc6/arch/mips/pci/Makefile
===================================================================
--- linux-2.6.22-rc6.orig/arch/mips/pci/Makefile
+++ linux-2.6.22-rc6/arch/mips/pci/Makefile
@@ -50,3 +50,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_PCI_ADM5120) += fixup-adm5120.o ops-adm5120.o pci-adm5120.o
Index: linux-2.6.22-rc6/include/linux/pci_ids.h
===================================================================
--- linux-2.6.22-rc6.orig/include/linux/pci_ids.h
+++ linux-2.6.22-rc6/include/linux/pci_ids.h
@@ -1712,6 +1712,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+#define PCI_VENDOR_ID_ADMTEK 0x1317
+#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
+
#define PCI_VENDOR_ID_SIIG 0x131f
#define PCI_SUBVENDOR_ID_SIIG 0x131f
#define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000