1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 21:39:49 +03:00
openwrt-xburst/target/linux/generic-2.6/patches/004-extra_optimization.patch
nbd c92885c466 Upgrade to Linux 2.6.19
- Includes large parts of the patch from #1021 by dpalffy
- Includes RB532 NAND driver changes by n0-1



git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5789 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-12-14 16:41:33 +00:00

14 lines
516 B
Diff

diff -urN linux-2.6.19.old/Makefile linux-2.6.19.dev/Makefile
--- linux-2.6.19.old/Makefile 2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.dev/Makefile 2006-12-14 03:13:23.000000000 +0100
@@ -513,6 +513,9 @@
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)