1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-17 22:48:02 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.26/007-adm5120_pci.patch
juhosg a33ab5c6e9 [adm5120] initial 2.6.26 support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11946 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-07-26 19:53:34 +00:00

20 lines
634 B
Diff

--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
@@ -48,3 +48,4 @@
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
+obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
@@ -1707,6 +1707,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
+#define PCI_VENDOR_ID_ADMTEK 0x1317
+#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
+
#define PCI_VENDOR_ID_SIIG 0x131f
#define PCI_SUBVENDOR_ID_SIIG 0x131f
#define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000