1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-19 03:48:02 +03:00
openwrt-xburst/package/uboot-lantiq/patches/010-fix-mips-flags.patch
nbd f679e4f7e6 add uboot-lantiq (based on a patch contributed by Lantiq)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20561 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-03-28 22:40:32 +00:00

24 lines
510 B
Diff

--- a/cpu/mips/config.mk
+++ b/cpu/mips/config.mk
@@ -23,16 +23,18 @@
v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
MIPSFLAGS:=$(shell \
if [ "$v" -lt "14" ]; then \
- echo "-mcpu=4kc"; \
+ echo "-mcpu=mips32"; \
else \
- echo "-march=4kc -mtune=4kc"; \
+ echo "-mips32 -march=mips32 -mtune=mips32"; \
fi)
+ifndef ENDIANNESS
ifneq (,$(findstring 4KCle,$(CROSS_COMPILE)))
ENDIANNESS = -EL
else
ENDIANNESS = -EB
endif
+endif
MIPSFLAGS += $(ENDIANNESS)