1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 23:24:37 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.34/620-phy_adm6996.patch
lars 8db5903195 [kernel] Add checksum for 2.6.34, refresh 2.6.34 patches and update targets from 2.6.34-rcX to 2.6.34
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21498 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-05-17 22:05:07 +00:00

25 lines
789 B
Diff

--- a/drivers/net/phy/Kconfig
+++ b/drivers/net/phy/Kconfig
@@ -93,6 +93,11 @@ config MICREL_PHY
---help---
Supports the KSZ9021, VSC8201, KS8001 PHYs.
+config ADM6996_PHY
+ tristate "Driver for ADM6996 switches"
+ ---help---
+ Currently supports the ADM6996F switch
+
config FIXED_PHY
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
depends on PHYLIB=y
--- a/drivers/net/phy/Makefile
+++ b/drivers/net/phy/Makefile
@@ -13,6 +13,7 @@ obj-$(CONFIG_VITESSE_PHY) += vitesse.o
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+obj-$(CONFIG_ADM6996_PHY) += adm6996.o
obj-$(CONFIG_REALTEK_PHY) += realtek.o
obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
obj-$(CONFIG_FIXED_PHY) += fixed.o