1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 15:25:06 +03:00
openwrt-xburst/target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch
florian 255ca55ed2 [rdc] fix 2.6.30 lzma tuning patch to output file size at end of kernel, otherwise decompressor remains stuck
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21458 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-05-15 19:15:10 +00:00

24 lines
1.1 KiB
Diff

Index: linux-2.6.30.10/scripts/Makefile.lib
===================================================================
--- linux-2.6.30.10.orig/scripts/Makefile.lib 2010-05-15 16:46:57.000000000 +0200
+++ linux-2.6.30.10/scripts/Makefile.lib 2010-05-15 18:53:02.000000000 +0200
@@ -204,4 +204,4 @@
# ---------------------------------------------------------------------------
quiet_cmd_lzma = LZMA $@
-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
+cmd_lzma = (lzma e $< -lc8 -eos -so && $(size_append) $<) > $@ || (rm -f $@ ; false)
Index: linux-2.6.30.10/arch/x86/include/asm/boot.h
===================================================================
--- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h 2010-05-15 16:45:57.000000000 +0200
+++ linux-2.6.30.10/arch/x86/include/asm/boot.h 2010-05-15 16:46:58.000000000 +0200
@@ -13,7 +13,7 @@
+ (CONFIG_PHYSICAL_ALIGN - 1)) \
& ~(CONFIG_PHYSICAL_ALIGN - 1))
-#ifdef CONFIG_KERNEL_BZIP2
+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
#define BOOT_HEAP_SIZE 0x400000
#else /* !CONFIG_KERNEL_BZIP2 */