mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-05 13:16:14 +02:00
1b16374fc8
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2682 3c298f89-4303-0410-b956-a3cf2f4a3e73
35 lines
1.2 KiB
Diff
35 lines
1.2 KiB
Diff
diff -ruN asterisk-1.2.0-old/apps/Makefile asterisk-1.2.0-new/apps/Makefile
|
|
--- asterisk-1.2.0-old/apps/Makefile 2005-11-11 01:32:45.000000000 +0100
|
|
+++ asterisk-1.2.0-new/apps/Makefile 2005-12-04 19:26:20.000000000 +0100
|
|
@@ -83,6 +83,9 @@
|
|
#CFLAGS+=-DEXTENDED_ODBC_STORAGE
|
|
# See doc/README.odbcstorage for more information
|
|
|
|
+CFLAGS += $(EXTRA_CFLAGS)
|
|
+APPS += $(EXTRA_APP_MODULES)
|
|
+
|
|
all: $(APPS)
|
|
|
|
clean:
|
|
@@ -102,14 +105,17 @@
|
|
app_curl.so: app_curl.o
|
|
$(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} $(CURLLIBS)
|
|
|
|
+app_sql_mysql.so: app_sql_mysql.o
|
|
+ $(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} $(EXTRA_LDFLAGS) -lmysqlclient
|
|
+
|
|
app_sql_postgres.o: app_sql_postgres.c
|
|
- $(CC) -pipe -I/usr/local/pgsql/include $(CFLAGS) -c -o app_sql_postgres.o app_sql_postgres.c
|
|
+ $(CC) -pipe $(CFLAGS) -c -o app_sql_postgres.o app_sql_postgres.c
|
|
|
|
app_sql_postgres.so: app_sql_postgres.o
|
|
- $(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} -L/usr/local/pgsql/lib -lpq
|
|
+ $(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} $(EXTRA_LDFLAGS) -lpq
|
|
|
|
app_sql_odbc.so: app_sql_odbc.o
|
|
- $(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} -lodbc
|
|
+ $(CC) $(SOLINK) -o $@ ${CYGSOLINK} $< ${CYGSOLIB} $(EXTRA_LDFLAGS) -lodbc
|
|
|
|
look: look.c
|
|
$(CC) -pipe -O6 -g look.c -o look -lncurses
|