1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 17:19:53 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
juhosg 9c609b5b3b [kernel] update to 2.6.25.15 and 2.6.26.2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12242 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-08-07 16:52:52 +00:00

22 lines
648 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -200,4 +200,11 @@
tristate "LED Morse Trigger"
depends on LEDS_TRIGGERS
+config LEDS_TRIGGER_NETDEV
+ tristate "LED Netdev Trigger"
+ depends on LEDS_TRIGGERS
+ help
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -29,3 +29,4 @@
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o