1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-15 15:53:09 +03:00
openwrt-xburst/package/opkg/patches/004-host_cpu.patch
nbd f90088e820 fix opkg target arch detection problem on x86
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14055 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-16 16:22:01 +00:00

21 lines
913 B
Diff

--- a/libbb/Makefile.am
+++ b/libbb/Makefile.am
@@ -1,6 +1,6 @@
HOST_CPU=@host_cpu@
BUILD_CPU=@build_cpu@
-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@
+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
noinst_LTLIBRARIES = libbb.la
--- a/libopkg/Makefile.am
+++ b/libopkg/Makefile.am
@@ -1,5 +1,6 @@
-AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
+HOST_CPU=@host_cpu@
+AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
libopkg_includedir=$(includedir)/libopkg
libopkg_include_HEADERS= opkg.h