1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 22:35:22 +03:00
openwrt-xburst/target/linux/adm5120/patches-2.6.28/009-adm5120_leds_switch_trigger.patch
juhosg 6f9076c67d [adm5120] refresh 2.6.28 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14198 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-01-26 07:59:54 +00:00

23 lines
830 B
Diff

--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
@@ -234,4 +234,12 @@ config LEDS_TRIGGER_NETDEV
This allows LEDs to be controlled by network device activity.
If unsure, say Y.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
+ depends on LEDS_TRIGGERS && ADM5120
+ help
+ This allows LEDs to be controlled by the port states of
+ the ADM5120 built-in Ethernet Switch
+ If unsure, say N.
+
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
@@ -33,3 +33,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o