1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 19:48:47 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.24/010-disable_old_squashfs_compatibility.patch
kaloz 95571be1fb refresh generic 2.6.24 patches to match upstream style
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11302 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-30 17:19:24 +00:00

20 lines
517 B
Diff

--- a/fs/squashfs/Makefile
+++ b/fs/squashfs/Makefile
@@ -4,4 +4,3 @@
obj-$(CONFIG_SQUASHFS) += squashfs.o
squashfs-y += inode.o
-squashfs-y += squashfs2_0.o
--- a/fs/squashfs/squashfs.h
+++ b/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)