1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-12 07:08:03 +03:00
openwrt-xburst/target/linux/generic/patches-3.2/350-arm_compressed_size.patch
nbd 549a939951 kernel: fix arm compressed images build on mac os x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31274 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-04-13 13:38:45 +00:00

12 lines
556 B
Diff

--- a/arch/arm/boot/compressed/Makefile
+++ b/arch/arm/boot/compressed/Makefile
@@ -127,7 +127,7 @@ ccflags-y := -fpic -fno-builtin -I$(obj)
asflags-y := -Wa,-march=all
# Supply kernel BSS size to the decompressor via a linker symbol.
-KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
+KBSS_SZ = $(shell $(CROSS_COMPILE)size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
LDFLAGS_vmlinux = --defsym _kernel_bss_size=$(KBSS_SZ)
# Supply ZRELADDR to the decompressor via a linker symbol.
ifneq ($(CONFIG_AUTO_ZRELADDR),y)