1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-16 01:50:02 +03:00
openwrt-xburst/target/linux/s3c24xx/patches-2.6.30/014-neo1973_mach.patch
lars fb189822fc [s3c24xx] bump to 2.6.30-rc6
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15918 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-05-18 17:55:41 +00:00

51 lines
1.8 KiB
Diff

Index: linux-2.6.30-rc6/arch/arm/plat-s3c24xx/Kconfig
===================================================================
--- linux-2.6.30-rc6.orig/arch/arm/plat-s3c24xx/Kconfig 2009-05-18 19:08:29.000000000 +0200
+++ linux-2.6.30-rc6/arch/arm/plat-s3c24xx/Kconfig 2009-05-18 19:08:31.000000000 +0200
@@ -112,4 +112,20 @@
help
Common machine code for SMDK2410 and SMDK2440
+config MACH_NEO1973
+ bool
+ select RFKILL
+ select SERIAL_SAMSUNG
+ select SERIAL_SAMSUNG_CONSOLE
+ help
+ Common machine code for Neo1973 hardware
+
+config MACH_NEO1973
+ bool
+ select RFKILL
+ select SERIAL_SAMSUNG
+ select SERIAL_SAMSUNG_CONSOLE
+ help
+ Common machine code for Neo1973 hardware
+
endif
Index: linux-2.6.30-rc6/arch/arm/mach-s3c2442/Makefile
===================================================================
--- linux-2.6.30-rc6.orig/arch/arm/mach-s3c2442/Makefile 2009-05-16 06:12:57.000000000 +0200
+++ linux-2.6.30-rc6/arch/arm/mach-s3c2442/Makefile 2009-05-18 19:08:31.000000000 +0200
@@ -14,3 +14,9 @@
# Machine support
+obj-$(CONFIG_MACH_NEO1973) += \
+ gta02-pm-gsm.o \
+ gta02-pm-gps.o \
+ gta02-pm-bt.o \
+ gta02-pm-wlan.o \
+ gta02-shadow.o
Index: linux-2.6.30-rc6/drivers/misc/Makefile
===================================================================
--- linux-2.6.30-rc6.orig/drivers/misc/Makefile 2009-05-16 06:12:57.000000000 +0200
+++ linux-2.6.30-rc6/drivers/misc/Makefile 2009-05-18 19:08:31.000000000 +0200
@@ -21,3 +21,6 @@
obj-$(CONFIG_ISL29003) += isl29003.o
obj-$(CONFIG_C2PORT) += c2port/
obj-y += eeprom/
+obj-$(CONFIG_MACH_NEO1973) += gta02_pm_host.o \
+ gta02_pm_resume_reason.o
+