1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 15:19:19 +03:00
openwrt-xburst/target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch
juhosg ad97a944cc [kernel] update to 2.6.27.10
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13695 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-12-19 19:25:35 +00:00

30 lines
827 B
Diff

--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
@@ -102,6 +102,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
# PARISC Architecture
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
@@ -704,6 +704,16 @@ config TXX9_WDT
help
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+config BCM63XX_WDT
+ tristate "Broadcom BCM63xx hardware watchdog"
+ depends on BCM63XX
+ help
+ Watchdog driver for the built in watchdog hardware in Broadcom
+ BCM63xx SoC.
+
+ To compile thi driver as a loadable module, choose M here.
+ The module will be called bcm63xx_wdt.
+
# PARISC Architecture
# POWERPC Architecture