1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:51:10 +03:00
openwrt-xburst/target/linux/brcm63xx/patches-2.6.27/050-spi.patch
hauke f958348e19 [kernel] refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15018 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-03-24 15:09:20 +00:00

27 lines
832 B
Diff

--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
@@ -217,6 +217,13 @@ config SPI_XILINX
See the "OPB Serial Peripheral Interface (SPI) (v1.00e)"
Product Specification document (DS464) for hardware details.
+config SPI_BCM63XX
+ tristate "Broadcom BCM63xx SPI controller"
+ depends on BCM63XX
+ select SPI_BITBANG
+ help
+ SPI driver for the Broadcom BCM63xx SPI controller.
+
#
# Add new SPI master controllers in alphabetical order above this line
#
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
@@ -30,6 +30,7 @@ obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24x
obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
+obj-$(CONFIG_SPI_BCM63XX) += bcm63xx_spi.o
# ... add above this line ...
# SPI protocol drivers (device/link on bus)