1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:18:05 +03:00
openwrt-xburst/target/linux/generic-2.4/patches/010-disable_old_squashfs_compatibility.patch
juhosg f3016ce71f [kernel] refresh generic-2.4 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11213 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-19 13:44:11 +00:00

28 lines
848 B
Diff

Index: linux-2.4.35.4/fs/squashfs/Makefile
===================================================================
--- linux-2.4.35.4.orig/fs/squashfs/Makefile
+++ linux-2.4.35.4/fs/squashfs/Makefile
@@ -4,7 +4,7 @@
O_TARGET := squashfs.o
-obj-y := inode.o squashfs2_0.o LzmaDecode.o
+obj-y := inode.o LzmaDecode.o
obj-m := $(O_TARGET)
Index: linux-2.4.35.4/fs/squashfs/squashfs.h
===================================================================
--- linux-2.4.35.4.orig/fs/squashfs/squashfs.h
+++ linux-2.4.35.4/fs/squashfs/squashfs.h
@@ -24,6 +24,9 @@
#ifdef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#undef CONFIG_SQUASHFS_1_0_COMPATIBILITY
#endif
+#ifdef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#undef CONFIG_SQUASHFS_2_0_COMPATIBILITY
+#endif
#ifdef SQUASHFS_TRACE
#define TRACE(s, args...) printk(KERN_NOTICE "SQUASHFS: "s, ## args)
#else