1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-13 14:03:41 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.26/004-extra_optimization.patch
juhosg 0f80ce2088 [kernel] refresh 2.6.26 patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13135 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-11-06 20:55:33 +00:00

13 lines
365 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -537,6 +537,9 @@ endif
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
CHECKFLAGS += $(NOSTDINC_FLAGS)
+# improve gcc optimization
+CFLAGS += $(call cc-option,-funit-at-a-time,)
+
# warn about C99 declaration after statement
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)