1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 06:50:43 +03:00
openwrt-xburst/target/linux/magicbox/patches/100-cf_slot.patch
juhosg d0a84e4ca8 [magicbox] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11205 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-19 11:05:50 +00:00

54 lines
1.7 KiB
Diff

Index: linux-2.6.24.7/drivers/ide/ide.c
===================================================================
--- linux-2.6.24.7.orig/drivers/ide/ide.c
+++ linux-2.6.24.7/drivers/ide/ide.c
@@ -1563,6 +1563,7 @@ done:
extern void __init pnpide_init(void);
extern void __exit pnpide_exit(void);
extern void __init h8300_ide_init(void);
+extern void __init ide_magicbox_init(void);
/*
* probe_for_hwifs() finds/initializes "known" IDE interfaces
@@ -1627,6 +1628,9 @@ static void __init probe_for_hwifs (void
#ifdef CONFIG_H8300
h8300_ide_init();
#endif
+#ifdef CONFIG_BLK_DEV_MAGICBOX_IDE
+ ide_magicbox_init();
+#endif
}
/*
Index: linux-2.6.24.7/drivers/ide/Kconfig
===================================================================
--- linux-2.6.24.7.orig/drivers/ide/Kconfig
+++ linux-2.6.24.7/drivers/ide/Kconfig
@@ -1018,6 +1018,14 @@ config BLK_DEV_MPC8xx_IDE
If unsure, say N.
+config BLK_DEV_MAGICBOX_IDE
+ bool "MagicBox 2.0 CF IDE support"
+ depends on 4xx && IDE
+ help
+ This option provides support for IDE on MagicBox 2.0 boards.
+
+ If unsure, say N.
+
choice
prompt "Type of MPC8xx IDE interface"
depends on BLK_DEV_MPC8xx_IDE
Index: linux-2.6.24.7/drivers/ide/Makefile
===================================================================
--- linux-2.6.24.7.orig/drivers/ide/Makefile
+++ linux-2.6.24.7/drivers/ide/Makefile
@@ -37,6 +37,7 @@ ide-core-$(CONFIG_BLK_DEV_Q40IDE) += leg
# built-in only drivers from ppc/
ide-core-$(CONFIG_BLK_DEV_MPC8xx_IDE) += ppc/mpc8xx.o
ide-core-$(CONFIG_BLK_DEV_IDE_PMAC) += ppc/pmac.o
+ide-core-$(CONFIG_BLK_DEV_MAGICBOX_IDE) += ppc/magicbox_ide.o
# built-in only drivers from h8300/
ide-core-$(CONFIG_IDE_H8300) += h8300/ide-h8300.o