1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 19:32:32 +03:00
openwrt-xburst/target/linux/ar7/patches-2.6.25/110-flash.patch
juhosg 2b43286d28 [ar7] refresh kernel patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11196 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-19 07:06:35 +00:00

44 lines
1.7 KiB
Diff

Index: linux-2.6.25.4/drivers/mtd/Kconfig
===================================================================
--- linux-2.6.25.4.orig/drivers/mtd/Kconfig
+++ linux-2.6.25.4/drivers/mtd/Kconfig
@@ -168,6 +168,12 @@ config MTD_OF_PARTS
the partition map from the children of the flash node,
as described in Documentation/powerpc/booting-without-of.txt.
+config MTD_AR7_PARTS
+ tristate "TI AR7 partitioning support"
+ depends on MTD_PARTITIONS
+ ---help---
+ TI AR7 partitioning support
+
comment "User Modules And Translation Layers"
config MTD_CHAR
Index: linux-2.6.25.4/drivers/mtd/Makefile
===================================================================
--- linux-2.6.25.4.orig/drivers/mtd/Makefile
+++ linux-2.6.25.4/drivers/mtd/Makefile
@@ -12,6 +12,7 @@ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redbo
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
# 'Users' - code which presents functionality to userspace.
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
Index: linux-2.6.25.4/drivers/mtd/maps/physmap.c
===================================================================
--- linux-2.6.25.4.orig/drivers/mtd/maps/physmap.c
+++ linux-2.6.25.4/drivers/mtd/maps/physmap.c
@@ -87,7 +87,8 @@ static int physmap_flash_remove(struct p
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
#ifdef CONFIG_MTD_PARTITIONS
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
+ "ar7part", NULL };
#endif
static int physmap_flash_probe(struct platform_device *dev)