1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-09-20 04:23:16 +03:00
openwrt-xburst/target/linux/generic-2.6/patches-2.6.23/640-mvswitch.patch
nbd 79f8984b04 Add support for the ultra-crappy Marvell 88E6060, which is used in Fonera+ and the upcoming Fonera 2.0
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10876 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-04-20 08:29:01 +00:00

53 lines
1.8 KiB
Diff

Index: linux-2.6.23.16/drivers/net/phy/Kconfig
===================================================================
--- linux-2.6.23.16.orig/drivers/net/phy/Kconfig 2008-04-20 07:31:20.000000000 +0200
+++ linux-2.6.23.16/drivers/net/phy/Kconfig 2008-04-20 08:57:26.000000000 +0200
@@ -65,6 +65,12 @@
---help---
Currently supports the ADM6996F switch
+config MVSWITCH_PHY
+ tristate "Driver for Marvell switches"
+ select VLAN_8021Q
+ ---help---
+ Currently supports the Marvell 88E6060 switch.
+
config FIXED_PHY
tristate "Drivers for PHY emulation on fixed speed/link"
---help---
Index: linux-2.6.23.16/drivers/net/phy/Makefile
===================================================================
--- linux-2.6.23.16.orig/drivers/net/phy/Makefile 2008-04-20 07:31:20.000000000 +0200
+++ linux-2.6.23.16/drivers/net/phy/Makefile 2008-04-20 07:31:34.000000000 +0200
@@ -13,4 +13,5 @@
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
obj-$(CONFIG_FIXED_PHY) += fixed.o
Index: linux-2.6.23.16/drivers/net/phy/mdio_bus.c
===================================================================
--- linux-2.6.23.16.orig/drivers/net/phy/mdio_bus.c 2008-04-20 04:40:31.000000000 +0200
+++ linux-2.6.23.16/drivers/net/phy/mdio_bus.c 2008-04-20 07:34:08.000000000 +0200
@@ -35,6 +35,12 @@
#include <asm/irq.h>
#include <asm/uaccess.h>
+static void mdio_dev_release(struct device *dev)
+{
+ /* nothing to do */
+}
+
+
/**
* mdiobus_register - bring up all the PHYs on a given bus and attach them to bus
* @bus: target mii_bus
@@ -85,6 +91,7 @@
phydev->dev.parent = bus->dev;
phydev->dev.bus = &mdio_bus_type;
+ phydev->dev.release = mdio_dev_release;
snprintf(phydev->dev.bus_id, BUS_ID_SIZE, PHY_ID_FMT, bus->id, i);
phydev->bus = bus;