mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 11:43:08 +02:00
Merge branch 'master' of git@projects.qi-hardware.com:openwrt-packages
This commit is contained in:
commit
0652dc203f
@ -23,9 +23,10 @@ include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/cxxtools
|
||||
TITLE:=cxxtools
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=cxxtools
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+tntnet
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=fn-handle
|
||||
PKG_VERSION:=20100316
|
||||
PKG_REV:=748269bdcfd0cea82ff9e3a79f60a0c3bb3bd35b
|
||||
PKG_REV:=acacde7b404a544d214f4ee01231bf0193a7155d
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
|
@ -2,10 +2,12 @@
|
||||
# Copyright (C) 2008 OpenWrt.org
|
||||
START=40
|
||||
|
||||
DEVICE="/dev/input/event0"
|
||||
DEVICE_PW="/dev/input/event0"
|
||||
DEVICE_KB="/dev/input/event1"
|
||||
|
||||
start() {
|
||||
fnkeys $DEVICE &
|
||||
fnkeys $DEVICE_PW &
|
||||
fnkeys $DEVICE_KB &
|
||||
}
|
||||
|
||||
stop() {
|
||||
|
@ -24,7 +24,7 @@ define Package/guile
|
||||
TITLE:=guile
|
||||
SECTION:=lang
|
||||
CATEGORY:=Languages
|
||||
DEPENDS:=+libgmp +libpthread +libltdl
|
||||
DEPENDS:=+libgmp +libpthread +libltdl @BROKEN
|
||||
URL:=http://savannah.gnu.org/projects/guile/
|
||||
endef
|
||||
|
||||
@ -34,7 +34,7 @@ endef
|
||||
|
||||
TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
|
||||
|
||||
CONFIGURE_ARGS +=
|
||||
CONFIGURE_ARGS += --without-threads
|
||||
|
||||
define Package/guile/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
|
13
guile/patches/0001-disable-csqrt.patch
Normal file
13
guile/patches/0001-disable-csqrt.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 217ac83..c4c16fc 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -854,7 +854,7 @@ main (void)
|
||||
}]])],
|
||||
[guile_cv_use_csqrt=yes],
|
||||
[guile_cv_use_csqrt="no, glibc 2.3 bug"],
|
||||
- [guile_cv_use_csqrt="yes, hopefully (cross-compiling)"])])
|
||||
+ [guile_cv_use_csqrt="no, Ben NanoNote (cross-compiling)"])])
|
||||
case $guile_cv_use_csqrt in
|
||||
yes*)
|
||||
AC_DEFINE(HAVE_USABLE_CSQRT, 1, [Define to 1 if csqrt is bug-free])
|
@ -1,50 +0,0 @@
|
||||
diff --git a/configure b/configure
|
||||
index a57297d..98857ae 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -35053,6 +35053,8 @@ fi
|
||||
|
||||
if test "$with_threads" = pthreads; then
|
||||
|
||||
+cat >> /dev/null << end_pthread_attr_getstack_check_part1
|
||||
+
|
||||
{ $as_echo "$as_me:$LINENO: checking whether pthread_attr_getstack works for the main thread" >&5
|
||||
$as_echo_n "checking whether pthread_attr_getstack works for the main thread... " >&6; }
|
||||
old_CFLAGS="$CFLAGS"
|
||||
@@ -35121,12 +35123,15 @@ $as_echo "$ac_try_echo") >&5
|
||||
ac_status=$?
|
||||
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
+
|
||||
+end_pthread_attr_getstack_check_part1
|
||||
works=yes
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
||||
#define PTHREAD_ATTR_GETSTACK_WORKS 1
|
||||
_ACEOF
|
||||
|
||||
+cat >> /dev/null << end_pthread_attr_getstack_check_part2
|
||||
else
|
||||
$as_echo "$as_me: program exited with status $ac_status" >&5
|
||||
$as_echo "$as_me: failed program was:" >&5
|
||||
@@ -35138,6 +35143,7 @@ fi
|
||||
rm -rf conftest.dSYM
|
||||
rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
fi
|
||||
+end_pthread_attr_getstack_check_part2
|
||||
|
||||
|
||||
CFLAGS="$old_CFLAGS"
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 217ac83..c4c16fc 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -854,7 +854,7 @@ main (void)
|
||||
}]])],
|
||||
[guile_cv_use_csqrt=yes],
|
||||
[guile_cv_use_csqrt="no, glibc 2.3 bug"],
|
||||
- [guile_cv_use_csqrt="yes, hopefully (cross-compiling)"])])
|
||||
+ [guile_cv_use_csqrt="no, Ben NanoNote (cross-compiling)"])])
|
||||
case $guile_cv_use_csqrt in
|
||||
yes*)
|
||||
AC_DEFINE(HAVE_USABLE_CSQRT, 1, [Define to 1 if csqrt is bug-free])
|
@ -12,7 +12,7 @@ PKG_NAME:=stardict
|
||||
PKG_VERSION:=3.0.1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://downloads.sourceforge.net/stardict/
|
||||
PKG_SOURCE_URL:=http://stardictproject.googlecode.com/files/
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
Loading…
Reference in New Issue
Block a user