1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-06-29 00:15:08 +03:00

triggersad is now happy again!

triggerhappy from openwrt works just fine
This commit is contained in:
kyak 2011-05-10 19:56:56 +04:00 committed by Xiangfu Liu
parent 60ae3deb3b
commit 0f74ee4731
5 changed files with 0 additions and 106 deletions

View File

@ -1,55 +0,0 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=triggersad
PKG_VERSION:=0.1.3
PKG_REV:=f7c42167127fb8377f99440f943ab863433b14b5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=git://github.com/wertarbyte/triggerhappy
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
include $(INCLUDE_DIR)/package.mk
define Package/triggersad
MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
SECTION:=utils
CATEGORY:=Utilities
TITLE:=handle input events and run configured programs
URL:=http://github.com/wertarbyte/triggerhappy
endef
define Package/triggersad/description
triggerhappy - handle input events and run configured programs
The daemon thd can handle hotplugged input devices and is configured through
simple configuration files in /etc/triggerhappy/triggers.d/.
endef
MAKE_FLAGS += \
$(TARGET_CONFIGURE_OPTS) \
$(1)
MAKE_VARS += TOOLCHAIN_DIR=$(TOOLCHAIN_DIR)
define Package/triggersad/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_DIR) $(1)/etc/triggerhappy
$(INSTALL_DIR) $(1)/etc/triggerhappy/triggers.d/
$(INSTALL_DIR) $(1)/etc/hotplug.d/input/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/thd $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/th-cmd $(1)/usr/sbin
$(INSTALL_BIN) ./files/triggerhappy.init $(1)/etc/init.d/triggerhappy
$(INSTALL_BIN) ./files/triggerhappy.hotplug $(1)/etc/hotplug.d/input/10-triggerhappy
$(INSTALL_BIN) ./files/triggerhappy-example.conf $(1)/etc/triggerhappy/triggers.d/example.conf
endef
$(eval $(call BuildPackage,triggersad))

View File

@ -1,14 +0,0 @@
# This is an example configuration for the triggerhappy daemon (thd)
# please note that every file to be processed must end in ".conf"
#
# To view a list of supported event codes, use "thd --listevents" or
# "thd --dump /dev/input/event*"
#
# Format:
# <eventcode> <value> <command>
#
# values for key events are 1 (pressed), 0 (released) or 2 (held)
#
## control an mpd instance
# KEY_NEXTSONG 1 /usr/bin/mpc next
# KEY_PREVSONG 1 /usr/bin/mpc prev

View File

@ -1,15 +0,0 @@
#!/bin/sh
THD_SOCKET=/tmp/triggerhappy.socket
[ -S "$THD_SOCKET" ] || exit
case "$ACTION" in
add)
DEVICE="/dev/$DEVNAME"
[ -c "$DEVICE" ] || exit
# offer device to triggerhappy daemon
/usr/sbin/th-cmd --socket "$THD_SOCKET" --add "$DEVICE"
;;
remove)
# nothing to do
;;
esac

View File

@ -1,10 +0,0 @@
#!/bin/sh /etc/rc.common
START=93
start() {
/usr/sbin/thd --socket /tmp/triggerhappy.socket --triggers /etc/triggerhappy/triggers.d/ --daemon /dev/input/event*
}
stop() {
/usr/sbin/th-cmd --socket /tmp/triggerhappy.socket --quit
}

View File

@ -1,12 +0,0 @@
diff -ur triggerhappy-0.1.3.orig/Makefile triggerhappy-0.1.3/Makefile
--- triggerhappy-0.1.3.orig/Makefile 2010-11-18 11:42:08.402150170 +0300
+++ triggerhappy-0.1.3/Makefile 2010-11-18 12:09:55.033025473 +0300
@@ -23,7 +23,7 @@
--release="" \
$< > $@
-evtable_%.h: /usr/include/linux/input.h
+evtable_%.h: $(TOOLCHAIN_DIR)/usr/include/linux/input.h
awk '/^#define $*_/ && $$2 !~ /_(MAX|CNT|VERSION)$$/ {print "EV_MAP("$$2"),"}' $< > $@
clean: