1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-06-26 03:56:43 +03:00

fbida: a few applications for viewing and editing images; ghostscript as

a requirement for fbgs, a wrapper script for viewing ps/pdf files on the
framebuffer console using fbi, an image viewer for the linux framebuffer
console.
This commit is contained in:
kyak 2010-10-18 20:39:48 +04:00
parent 1a6e2dc80b
commit 277888f878
5 changed files with 159 additions and 0 deletions

57
fbida/Makefile Normal file
View File

@ -0,0 +1,57 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=fbida
PKG_VERSION:=2.07
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dl.bytesex.org/releases/fbida/
PKG_MD5SUM:=3e05910fb7c1d9b2bd3e272d96db069c
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/fbida
SUBMENU:=fbida
SECTION:=utils
CATEGORY:=Utilities
URL:=http://linux.bytesex.org/fbida/
DEPENDS:=+libpng +libtiff +libexif +libiconv +dejavu-fonts-ttf
endef
define Package/fbida/description
The fbida project contains a few applications for viewing and editing images
endef
define Package/fbi
$(call Package/fbida)
TITLE:=This is a image viewer for the linux framebuffer console.
endef
define Package/fbgs
$(call Package/fbida)
TITLE:=A wrapper script for viewing ps/pdf files on the framebuffer console using fbi.
DEPENDS:=+fbi +ghostscript
endef
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libiconv/include
TARGET_LDFLAGS+=-L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
define Package/fbi/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/{fbi,exiftran} $(1)/usr/bin/
endef
define Package/fbgs/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/fbgs $(1)/usr/bin/
endef
$(eval $(call BuildPackage,fbi))
$(eval $(call BuildPackage,fbgs))

View File

@ -0,0 +1,10 @@
--- fbida-2.07.orig/fbtools.c 2008-10-11 12:49:38.676243745 +0200
+++ fbida-2.07/fbtools.c 2008-10-11 12:50:08.286262765 +0200
@@ -519,6 +519,6 @@
/* cleanup */
fb_cleanup();
- fprintf(stderr,"Oops: %s\n",sys_siglist[termsig]);
+ fprintf(stderr,"Oops: %s\n",strsignal(termsig));
exit(42);
}

View File

@ -0,0 +1,11 @@
--- fbida-2.07.orig/fbi.c 2010-10-17 19:08:40.726246881 +0400
+++ fbida-2.07/fbi.c 2010-10-17 19:08:35.322244313 +0400
@@ -1465,7 +1465,7 @@
font_init();
if (NULL == fontname)
- fontname = "monospace:size=16";
+ fontname = "monospace:size=10";
face = font_open(fontname);
if (NULL == face) {
fprintf(stderr,"can't open font: %s\n",fontname);

View File

@ -0,0 +1,12 @@
--- fbida-2.07.orig/fbgs 2010-10-18 20:26:32.264246468 +0400
+++ fbida-2.07/fbgs 2010-10-18 20:26:57.179244034 +0400
@@ -1,7 +1,7 @@
-#!/bin/bash
+#!/bin/sh
# tmp dir
-DIR="$(mktemp -dtp ${TMPDIR-/var/tmp} fbgs-XXXXXX)"
+DIR="$(mktemp -dtp ${TMPDIR-/tmp} fbgs-XXXXXX)"
test -d "$DIR" || exit 1
trap "rm -rf $DIR" EXIT

69
gs/Makefile Normal file
View File

@ -0,0 +1,69 @@
#
# This is free software, licensed under the GNU General Public License v2.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=ghostscript
PKG_VERSION:=9.00
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ghostscript.com/releases/
PKG_MD5SUM:=a402462478b4cdda3e1816899227b845
include $(INCLUDE_DIR)/package.mk
define Package/ghostscript
SECTION:=utils
CATEGORY:=Utilities
TITLE:=interpreter for the PostScript language and for PDF
URL:=http://pages.cs.wisc.edu/~ghost/
DEPENDS:=+libtiff +libiconv +libpng +fontconfig +libfreetype
endef
define Package/ghostscript/description
Ghostscript is an interpreter for the PostScript language and for PDF
endef
define Build/Prepare
$(call Build/Prepare/Default)
mkdir $(PKG_BUILD_DIR)/obj
#(cd $(PKG_BUILD_DIR); ./configure;);
#make -C $(PKG_BUILD_DIR) obj/arch.h obj/genconf obj/echogs
for i in genarch genconf echogs; do \
gcc -O2 -Wall -Wstrict-prototypes -Wundef -Wmissing-declarations -Wmissing-prototypes -Wwrite-strings -Wno-strict-aliasing -Wdeclaration-after-statement -fno-builtin -fno-common -DHAVE_STDINT_H -DGX_COLOR_INDEX_TYPE="unsigned long long" -I$(PKG_BUILD_DIR)/base -o $(PKG_BUILD_DIR)/obj/$$$$i $(PKG_BUILD_DIR)/base/$$$$i.c; \
done
endef
TARGET_CFLAGS+= \
-I$(STAGING_DIR)/usr/lib/libiconv/include \
TARGET_LDFLAGS+= \
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-L$(STAGING_DIR)/usr/lib/libiconv/lib
CONFIGURE_ARGS += \
--with-system-libtiff \
--with-libiconv=gnu \
--without-x \
--without-jbig2dec \
--without-jasper
MAKE_FLAGS += \
EXTRALIBS="-L$(STAGING_DIR)/usr/lib/libiconv/lib -L$(STAGING_DIR)/usr/lib -lfontconfig -lfreetype -liconv -ldl -Wl,-rpath-link=$(STAGING_DIR)/usr/lib" \
COMPILE_INITS="0"
define Package/ghostscript/install
$(INSTALL_DIR) \
$(1)/usr/bin $(1)/usr/share/$(PKG_NAME)/$(PKG_VERSION)
$(INSTALL_BIN) \
$(PKG_BUILD_DIR)/bin/gs \
$(1)/usr/bin/gs
$(CP) $(PKG_BUILD_DIR)/{Resource,lib,iccprofiles} \
$(1)/usr/share/$(PKG_NAME)/$(PKG_VERSION)/
endef
$(eval $(call BuildPackage,ghostscript))