1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-09-30 00:45:07 +03:00

[stardict] forget the nls.m4 file

This commit is contained in:
Xiangfu Liu 2010-02-17 20:47:15 +08:00
parent 2f54020861
commit 2cb344aeac

View File

@ -7,13 +7,15 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
configure |28488 +++++++++++++++++++------------------------------
configure.in | 36
m4/nls.m4 | 31
src/Makefile.am | 6
src/class_factory.cpp | 4
src/conf.cpp | 4
src/desktop.cpp | 2
src/mainwin.cpp | 7
src/stardict.cpp | 40
8 files changed, 11174 insertions(+), 17413 deletions(-)
9 files changed, 11205 insertions(+), 17413 deletions(-)
create mode 100644 m4/nls.m4
diff --git a/configure b/configure
@ -34736,6 +34738,43 @@ index 83d3d95..4b15e43 100644
"
+
diff --git a/m4/nls.m4 b/m4/nls.m4
new file mode 100644
index 0000000..7967cc2
--- /dev/null
+++ b/m4/nls.m4
@@ -0,0 +1,31 @@
+# nls.m4 serial 3 (gettext-0.15)
+dnl Copyright (C) 1995-2003, 2005-2006 Free Software Foundation, Inc.
+dnl This file is free software; the Free Software Foundation
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+dnl This file can can be used in projects which are not available under
+dnl the GNU General Public License or the GNU Library General Public
+dnl License but which still want to provide support for the GNU gettext
+dnl functionality.
+dnl Please note that the actual code of the GNU gettext library is covered
+dnl by the GNU Library General Public License, and the rest of the GNU
+dnl gettext package package is covered by the GNU General Public License.
+dnl They are *not* in the public domain.
+
+dnl Authors:
+dnl Ulrich Drepper <drepper@cygnus.com>, 1995-2000.
+dnl Bruno Haible <haible@clisp.cons.org>, 2000-2003.
+
+AC_PREREQ(2.50)
+
+AC_DEFUN([AM_NLS],
+[
+ AC_MSG_CHECKING([whether NLS is requested])
+ dnl Default is enabled NLS
+ AC_ARG_ENABLE(nls,
+ [ --disable-nls do not use Native Language Support],
+ USE_NLS=$enableval, USE_NLS=yes)
+ AC_MSG_RESULT($USE_NLS)
+ AC_SUBST(USE_NLS)
+])
diff --git a/src/Makefile.am b/src/Makefile.am
index bca4861..1499775 100644
--- a/src/Makefile.am