1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-02 21:28:54 +03:00

plplot: fix compile problem on ubuntu 10.10 hosts (host's libm not found)

This commit is contained in:
David Kühling 2011-05-26 23:43:23 +02:00
parent c0d17b1b4b
commit 54cdac86d6
3 changed files with 21 additions and 4 deletions

View File

@ -28,7 +28,8 @@ include $(INCLUDE_DIR)/package.mk
CMAKE_HOST_FLAGS=-DCMAKE_INSTALL_PREFIX=/usr \
-DDEFAULT_NO_DEVICES=ON \
-DPKG_CONFIG_EXECUTABLE=Not-Found -DDEFAULT_NO_BINDINGS=ON
-DPKG_CONFIG_EXECUTABLE=Not-Found -DDEFAULT_NO_BINDINGS=ON \
-DCMAKE_EXE_LINKER_FLAGS=-lm
## Need host-compiled plplot build dir for cmake to work for the target
define Host/Configure
@ -44,7 +45,7 @@ endef
define Host/Compile
$(if $(CONFIG_PACKAGE_plplot-octave),$(Host/Compile/Octave),)
$(MAKE) -C $(HOST_BUILD_DIR)/build_dir VERBOSE=1 -j4
$(MAKE) -C $(HOST_BUILD_DIR)/build_dir VERBOSE=1 -j4
endef
define Host/Install/Octave

View File

@ -0,0 +1,16 @@
Index: plplot-5.9.7/cmake/modules/plplot.cmake
===================================================================
--- plplot-5.9.7.orig/cmake/modules/plplot.cmake 2011-05-26 20:55:13.000000000 +0200
+++ plplot-5.9.7/cmake/modules/plplot.cmake 2011-05-26 21:03:13.000000000 +0200
@@ -481,9 +481,9 @@
# On windows systems the math library is not separated so do not specify
# it unless you are on a non-windows system.
if(NOT WIN32)
- find_library(MATH_LIB NAMES m PATHS /usr/local/lib /usr/lib)
+ find_library(MATH_LIB NAMES m PATHS /usr/local/lib /usr/lib /lib)
if(NOT MATH_LIB)
- message(FATAL_ERROR "Cannot find required math library")
+ message("Cannot find required math library, continuing anyway")
endif(NOT MATH_LIB)
endif(NOT WIN32)
# Must come after MATH_LIB is defined (or not).

View File

@ -1,7 +1,7 @@
Index: plplot-5.9.7/cmake/modules/plplot.cmake
===================================================================
--- plplot-5.9.7.orig/cmake/modules/plplot.cmake 2011-02-15 22:31:43.000000000 +0100
+++ plplot-5.9.7/cmake/modules/plplot.cmake 2011-02-15 22:32:09.000000000 +0100
--- plplot-5.9.7.orig/cmake/modules/plplot.cmake 2011-05-26 20:25:37.000000000 +0200
+++ plplot-5.9.7/cmake/modules/plplot.cmake 2011-05-26 20:25:37.000000000 +0200
@@ -493,7 +493,8 @@
# =======================================================================
# libpango support