mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 06:03:08 +02:00
bard: fix the FLITEDIR and SDL check
This commit is contained in:
parent
836e6d066f
commit
5c470deb5c
@ -29,6 +29,13 @@ Bard Storyteller is a text reader. Bard not only allows a user to read books,
|
||||
but can also read books to a user using text-to-speech.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
cd $(PKG_BUILD_DIR) && autoconf
|
||||
$(call Build/Configure/Default, FLITEDIR=$(STAGING_DIR)/usr)
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||
|
||||
define Package/bard/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/bard $(1)/usr/bin/
|
||||
|
21
bard/patches/001-remove-configure-hardcode-check.patch
Normal file
21
bard/patches/001-remove-configure-hardcode-check.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff --git a/configure.in b/configure.in
|
||||
index 0e44011..254d1da 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -430,16 +430,6 @@ echo CMU Flite found in $FLITEDIR
|
||||
AC_SUBST(FLITEDIR)
|
||||
|
||||
dnl
|
||||
-dnl SDL support
|
||||
-dnl
|
||||
-if ! test -f /usr/include/SDL/SDL.h; then
|
||||
- AC_MSG_ERROR("Cannot locate /usr/include/SDL/SDL.h.")
|
||||
-fi
|
||||
-if ! test -f /usr/include/SDL/SDL_ttf.h; then
|
||||
- AC_MSG_ERROR("Cannot locate /usr/include/SDL/SDL_ttf.h.")
|
||||
-fi
|
||||
-
|
||||
-dnl
|
||||
dnl Find a font.
|
||||
dnl
|
||||
if test "x$DEFAULTFONT" = "x"
|
Loading…
Reference in New Issue
Block a user