mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-19 07:15:20 +02:00
Merge branch 'master' of projects.qi-hardware.com:openwrt-packages
This commit is contained in:
commit
7cc7b71ad1
52
climm/Makefile
Normal file
52
climm/Makefile
Normal file
@ -0,0 +1,52 @@
|
||||
# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=climm
|
||||
PKG_VERSION:=0.7.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=climm-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://www.climm.org/source/
|
||||
#PKG_MD5SUM:=887415d16c32af58eab2ec2d9bb17fa6
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/climm-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/climm
|
||||
SECTION:=network
|
||||
CATEGORY:=Network
|
||||
TITLE:=Climm
|
||||
DEPENDS:=+zlib +libncurses +libreadline +libintl +libcharset +libopenssl +libgnutls +libgnutls-openssl
|
||||
URL:=http://www.climm.org/
|
||||
endef
|
||||
|
||||
define Package/climm/description
|
||||
Terminal Jabber client.
|
||||
endef
|
||||
|
||||
EXTRA_CFLAGS += \
|
||||
-I$(STAGING_DIR)/usr/lib/libintl/include \
|
||||
-I$(STAGING_DIR)/usr/lib/libiconv/include \
|
||||
-I$(STAGING_DIR)/usr/include
|
||||
|
||||
EXTRA_LDFLAGS += \
|
||||
-L$(STAGING_DIR)/usr/lib/libintl/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib -lm -lz
|
||||
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--prefix=/usr --with-ssl \
|
||||
export READLINE=1 \
|
||||
)
|
||||
endef
|
||||
|
||||
define Package/climm/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/climm $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,climm))
|
41
odt2txt/Makefile
Normal file
41
odt2txt/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=odt2txt
|
||||
PKG_VERSION:=0.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=odt2txt-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://stosberg.net/odt2txt/
|
||||
PKG_MD5SUM:=6fe3bd261ce2dde2810244bbe969bbc5
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/odt2txt-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/odt2txt
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=odt2txt
|
||||
URL:=http://stosberg.net/odt2txt/
|
||||
DEPENDS:=+libiconv +zlib
|
||||
endef
|
||||
|
||||
define Package/odt2txt/description
|
||||
Converts OpenDocument files to plain text.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="-I$(STAGING_DIR)/usr/include -O2 -DNO_ICONV" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib " \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
define Package/odt2txt/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/odt2txt $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,odt2txt))
|
12
odt2txt/patches/Makefile.patch
Normal file
12
odt2txt/patches/Makefile.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- odt2txt-0.4/Makefile 2008-06-23 21:32:28.000000000 +0200
|
||||
+++ odt2txt-0.4m/Makefile 2010-07-23 14:19:20.706059237 +0200
|
||||
@@ -10,9 +10,7 @@
|
||||
CFLAGS = -O2
|
||||
endif
|
||||
|
||||
-ifdef NO_ICONV
|
||||
CFLAGS += -DNO_ICONV
|
||||
-endif
|
||||
|
||||
KUNZIP_OBJS = kunzip/fileio.o kunzip/zipfile.o
|
||||
OBJ = odt2txt.o regex.o mem.o strbuf.o $(KUNZIP_OBJS)
|
41
quickcalc/Makefile
Normal file
41
quickcalc/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=quickcalc
|
||||
PKG_VERSION:=1.26
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=quickcalc-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=ftp://ftp.ac-grenoble.fr/ge/mathematics/
|
||||
PKG_MD5SUM:=152599c038c06ecc11e7db9dad4d4dce
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/quickcalc-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/quickcalc
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=QuickCalc
|
||||
URL:=http://freshmeat.net/projects/quickcalc
|
||||
DEPENDS:=+libreadline +libncurses
|
||||
endef
|
||||
|
||||
define Package/quickcalc/description
|
||||
Computer algebra system.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="-I$(STAGING_DIR)/usr/include -O2 " \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib " \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
define Package/quickcalc/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/qc $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,quickcalc))
|
21
quickcalc/patches/Makefile.patch
Normal file
21
quickcalc/patches/Makefile.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- quickcalc-1.26/Makefile 1999-07-25 16:33:21.000000000 +0200
|
||||
+++ quickcalc-1.26m/Makefile 2010-07-23 13:13:02.888135597 +0200
|
||||
@@ -3,7 +3,8 @@
|
||||
#CPPFLAGS = -DC_DEBUG -g
|
||||
|
||||
CC = gcc
|
||||
-CFLAGS = -O2 -Wall
|
||||
+CFLAGS+= -O2 -Wall
|
||||
+LDLIBS+=$(LDFLAGS) -lm -lreadline -lncurses
|
||||
SHELL = /bin/sh
|
||||
|
||||
OBJS = qc.o error.o disp_ans.o text.o calc_str.o lex.yy.o
|
||||
@@ -11,7 +12,7 @@
|
||||
all : qc
|
||||
|
||||
qc : $(OBJS)
|
||||
- $(CC) $(OBJS) -lm -lreadline -lncurses -o qc
|
||||
+ $(CC) $(OBJS) $(LDLIBS) -o $(@)
|
||||
|
||||
qc.o : qc.c version.h
|
||||
|
Loading…
Reference in New Issue
Block a user