1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-11-22 07:08:05 +02:00

bard: update to 0.6 and disable mouse

This commit is contained in:
Xiangfu Liu 2012-01-30 09:59:45 +08:00
parent c36a307041
commit 927c833392
3 changed files with 42 additions and 3 deletions

View File

@ -6,7 +6,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bard
PKG_VERSION:=0.5
PKG_VERSION:=0.6
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-current.tar.bz2
PKG_SOURCE_URL:=http://festvox.org/bard/

View File

@ -1,8 +1,17 @@
From 2d451688f5fbacddf39de02f14ed1088f9414dd6 Mon Sep 17 00:00:00 2001
From: Xiangfu <xiangfu@openmobilefree.net>
Date: Mon, 30 Jan 2012 09:57:01 +0800
Subject: [PATCH 1/2] remove-configure-hardcode-path
---
configure.in | 10 ----------
1 files changed, 0 insertions(+), 10 deletions(-)
diff --git a/configure.in b/configure.in
index 0e44011..254d1da 100644
index d1a93e0..9288a3f 100644
--- a/configure.in
+++ b/configure.in
@@ -430,16 +430,6 @@ echo CMU Flite found in $FLITEDIR
@@ -443,16 +443,6 @@ echo CMU Flite found in $FLITEDIR
AC_SUBST(FLITEDIR)
dnl
@ -19,3 +28,6 @@ index 0e44011..254d1da 100644
dnl Find a font.
dnl
if test "x$DEFAULTFONT" = "x"
--
1.7.5.4

View File

@ -0,0 +1,27 @@
From 559fc9a590cf13af7bfce87af6b78e5bae21eff4 Mon Sep 17 00:00:00 2001
From: Xiangfu <xiangfu@openmobilefree.net>
Date: Mon, 30 Jan 2012 09:58:12 +0800
Subject: [PATCH 2/2] disable-mouse
---
src/display.c | 4 ++++
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/src/display.c b/src/display.c
index 620ad8a..91dd965 100644
--- a/src/display.c
+++ b/src/display.c
@@ -107,6 +107,10 @@ bard_display *bard_display_open(cst_features *config)
return NULL;
}
+#ifdef BARD_TARGET_BEN_NANONOTE
+ SDL_ShowCursor(SDL_DISABLE);
+#endif
+
return display;
}
--
1.7.5.4