1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-01 02:11:05 +03:00

svgalib: use faster non-paged drawing primitives

This commit is contained in:
David Kühling 2011-01-29 14:21:43 +01:00
parent f5d48e7a0f
commit 9c4f17115c
2 changed files with 14 additions and 1 deletions

View File

@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=svgalib
PKG_VERSION:=1.4.3
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.svgalib.org/
PKG_MD5SUM:=7d2778e3beebc07dd7c74668f6887c6f

View File

@ -0,0 +1,13 @@
Index: svgalib-1.4.3/gl/grlib.c
===================================================================
--- svgalib-1.4.3.orig/gl/grlib.c 2011-01-29 14:17:53.000000000 +0100
+++ svgalib-1.4.3/gl/grlib.c 2011-01-29 14:17:57.000000000 +0100
@@ -235,7 +235,7 @@
MODEFLAGS |= MODEFLAG_TRIPLEBUFFERING_CAPABLE;
} else if ((m == G320x200x256 && modeinfo->maxpixels <= 65536) ||
(modeinfo->flags & IS_LINEAR)
-#if 0 /* svgalib doesn't VT-switch correctly with linear addressing. */
+#if 1 /* svgalib doesn't VT-switch correctly with linear addressing. */
|| ((modeinfo->flags & CAPABLE_LINEAR)
/* Creepy. Try linear addressing only if the mode is set. */
&& vga_getcurrentmode() == m && (vga_setlinearaddressing() != -1))