mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-21 23:19:42 +02:00
[new package][hnb] hierarchical notebook. by Jirka
This commit is contained in:
parent
50c19aac96
commit
f5fb358d2f
41
hnb/Makefile
Normal file
41
hnb/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=hnb
|
||||
PKG_VERSION:=1.9.17
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/hnb
|
||||
TITLE:=hnb
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses
|
||||
URL:=http://hnb.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/hnb/description
|
||||
Powerfull outline editor/notebook for text console.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="-I$(STAGING_DIR)/usr/include -I. -I./src -I./src/libcli -I./libcli -I$(PKG_BUILD_DIR) -DHAVE_CONFIG_H " \
|
||||
LIBS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib libcli/libcli.a -lm -lncurses" \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
|
||||
define Package/hnb/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/hnb $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,hnb))
|
13
hnb/patches/Makefile-hnb.patch
Normal file
13
hnb/patches/Makefile-hnb.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- hnb-1.9.17/Makefile 2003-03-10 03:22:23.000000000 +0100
|
||||
+++ hnb-1.9.17m/Makefile 2010-07-08 14:39:46.000000000 +0200
|
||||
@@ -2,8 +2,8 @@
|
||||
src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
|
||||
(cd src;make)
|
||||
install: src/hnb
|
||||
- install -D src/hnb /usr/local/bin/hnb
|
||||
- install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
|
||||
+ #install -D src/hnb /usr/bin/hnb
|
||||
+ #install -D -m444 doc/hnb.1 /usr/man/man1/hnb.1
|
||||
clean:
|
||||
(cd src;make clean)
|
||||
(cd util;make clean)
|
Loading…
Reference in New Issue
Block a user