mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-01 15:18:26 +02:00
[adm5120] refresh .23 kernel paches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10366 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
799328ae8f
commit
007000ead9
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/arch/mips/Kconfig
|
||||
Index: linux-2.6.23.14/arch/mips/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/arch/mips/Kconfig
|
||||
+++ linux-2.6.23/arch/mips/Kconfig
|
||||
--- linux-2.6.23.14.orig/arch/mips/Kconfig
|
||||
+++ linux-2.6.23.14/arch/mips/Kconfig
|
||||
@@ -15,6 +15,18 @@ choice
|
||||
prompt "System type"
|
||||
default SGI_IP22
|
||||
@ -29,10 +29,10 @@ Index: linux-2.6.23/arch/mips/Kconfig
|
||||
source "arch/mips/au1000/Kconfig"
|
||||
source "arch/mips/jazz/Kconfig"
|
||||
source "arch/mips/pmc-sierra/Kconfig"
|
||||
Index: linux-2.6.23/arch/mips/Makefile
|
||||
Index: linux-2.6.23.14/arch/mips/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/arch/mips/Makefile
|
||||
+++ linux-2.6.23/arch/mips/Makefile
|
||||
--- linux-2.6.23.14.orig/arch/mips/Makefile
|
||||
+++ linux-2.6.23.14/arch/mips/Makefile
|
||||
@@ -168,6 +168,16 @@ cflags-$(CONFIG_MACH_JAZZ) += -Iinclude/
|
||||
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
|
||||
|
||||
@ -50,10 +50,10 @@ Index: linux-2.6.23/arch/mips/Makefile
|
||||
# Common Alchemy Au1x00 stuff
|
||||
#
|
||||
core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/
|
||||
Index: linux-2.6.23/include/asm-mips/bootinfo.h
|
||||
Index: linux-2.6.23.14/include/asm-mips/bootinfo.h
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/include/asm-mips/bootinfo.h
|
||||
+++ linux-2.6.23/include/asm-mips/bootinfo.h
|
||||
--- linux-2.6.23.14.orig/include/asm-mips/bootinfo.h
|
||||
+++ linux-2.6.23.14/include/asm-mips/bootinfo.h
|
||||
@@ -208,6 +208,58 @@
|
||||
#define MACH_GROUP_WINDRIVER 28 /* Windriver boards */
|
||||
#define MACH_WRPPMC 1
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/mtd/maps/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/mtd/maps/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/maps/Kconfig
|
||||
+++ linux-2.6.23/drivers/mtd/maps/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/maps/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/mtd/maps/Kconfig
|
||||
@@ -614,5 +614,9 @@ config MTD_PLATRAM
|
||||
|
||||
This selection automatically selects the map_ram driver.
|
||||
@ -12,10 +12,10 @@ Index: linux-2.6.23/drivers/mtd/maps/Kconfig
|
||||
+
|
||||
endmenu
|
||||
|
||||
Index: linux-2.6.23/drivers/mtd/maps/Makefile
|
||||
Index: linux-2.6.23.14/drivers/mtd/maps/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/maps/Makefile
|
||||
+++ linux-2.6.23/drivers/mtd/maps/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/maps/Makefile
|
||||
+++ linux-2.6.23.14/drivers/mtd/maps/Makefile
|
||||
@@ -47,6 +47,7 @@ obj-$(CONFIG_MTD_OCELOT) += ocelot.o
|
||||
obj-$(CONFIG_MTD_SOLUTIONENGINE)+= solutionengine.o
|
||||
obj-$(CONFIG_MTD_PCI) += pci.o
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/net/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/net/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/net/Kconfig
|
||||
+++ linux-2.6.23/drivers/net/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/net/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/net/Kconfig
|
||||
@@ -589,6 +589,10 @@ config MIPS_AU1X00_ENET
|
||||
If you have an Alchemy Semi AU1X00 based system
|
||||
say Y. Otherwise, say N.
|
||||
@ -13,10 +13,10 @@ Index: linux-2.6.23/drivers/net/Kconfig
|
||||
config NET_SB1250_MAC
|
||||
tristate "SB1250 Ethernet support"
|
||||
depends on SIBYTE_SB1xxx_SOC
|
||||
Index: linux-2.6.23/drivers/net/Makefile
|
||||
Index: linux-2.6.23.14/drivers/net/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/net/Makefile
|
||||
+++ linux-2.6.23/drivers/net/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/net/Makefile
|
||||
+++ linux-2.6.23.14/drivers/net/Makefile
|
||||
@@ -174,6 +174,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
|
||||
# This is also a 82596 and should probably be merged
|
||||
obj-$(CONFIG_LP486E) += lp486e.o
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/mtd/nand/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/mtd/nand/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/nand/Kconfig
|
||||
+++ linux-2.6.23/drivers/mtd/nand/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/nand/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/mtd/nand/Kconfig
|
||||
@@ -81,6 +81,16 @@ config MTD_NAND_TS7250
|
||||
help
|
||||
Support for NAND flash on Technologic Systems TS-7250 platform.
|
||||
@ -19,10 +19,10 @@ Index: linux-2.6.23/drivers/mtd/nand/Kconfig
|
||||
config MTD_NAND_IDS
|
||||
tristate
|
||||
|
||||
Index: linux-2.6.23/drivers/mtd/nand/Makefile
|
||||
Index: linux-2.6.23.14/drivers/mtd/nand/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/nand/Makefile
|
||||
+++ linux-2.6.23/drivers/mtd/nand/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/nand/Makefile
|
||||
+++ linux-2.6.23.14/drivers/mtd/nand/Makefile
|
||||
@@ -10,6 +10,7 @@ obj-$(CONFIG_MTD_NAND_CAFE) += cafe_nan
|
||||
obj-$(CONFIG_MTD_NAND_SPIA) += spia.o
|
||||
obj-$(CONFIG_MTD_NAND_AMS_DELTA) += ams-delta.o
|
||||
|
@ -1,18 +1,18 @@
|
||||
Index: linux-2.6.23/drivers/usb/host/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/usb/host/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/usb/host/Kconfig
|
||||
+++ linux-2.6.23/drivers/usb/host/Kconfig
|
||||
@@ -261,3 +261,6 @@ config USB_R8A66597_HCD
|
||||
--- linux-2.6.23.14.orig/drivers/usb/host/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/usb/host/Kconfig
|
||||
@@ -248,3 +248,6 @@ config USB_R8A66597_HCD
|
||||
To compile this driver as a module, choose M here: the
|
||||
module will be called r8a66597-hcd.
|
||||
|
||||
+config USB_ADM5120_HCD
|
||||
+ tristate "ADM5120 HCD support (EXPERIMENTAL)"
|
||||
+ depends on USB && MIPS_ADM5120 && EXPERIMENTAL
|
||||
Index: linux-2.6.23/drivers/usb/host/Makefile
|
||||
Index: linux-2.6.23.14/drivers/usb/host/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/usb/host/Makefile
|
||||
+++ linux-2.6.23/drivers/usb/host/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/usb/host/Makefile
|
||||
+++ linux-2.6.23.14/drivers/usb/host/Makefile
|
||||
@@ -8,6 +8,7 @@ endif
|
||||
|
||||
obj-$(CONFIG_PCI) += pci-quirks.o
|
||||
@ -21,10 +21,10 @@ Index: linux-2.6.23/drivers/usb/host/Makefile
|
||||
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
|
||||
obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o
|
||||
obj-$(CONFIG_USB_OHCI_HCD) += ohci-hcd.o
|
||||
Index: linux-2.6.23/drivers/usb/Makefile
|
||||
Index: linux-2.6.23.14/drivers/usb/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/usb/Makefile
|
||||
+++ linux-2.6.23/drivers/usb/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/usb/Makefile
|
||||
+++ linux-2.6.23.14/drivers/usb/Makefile
|
||||
@@ -16,6 +16,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += host/
|
||||
obj-$(CONFIG_USB_SL811_HCD) += host/
|
||||
obj-$(CONFIG_USB_U132_HCD) += host/
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/leds/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/leds/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/leds/Kconfig
|
||||
+++ linux-2.6.23/drivers/leds/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/leds/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/leds/Kconfig
|
||||
@@ -18,6 +18,21 @@ config LEDS_CLASS
|
||||
|
||||
comment "LED drivers"
|
||||
@ -24,10 +24,10 @@ Index: linux-2.6.23/drivers/leds/Kconfig
|
||||
config LEDS_CORGI
|
||||
tristate "LED Support for the Sharp SL-C7x0 series"
|
||||
depends on LEDS_CLASS && PXA_SHARP_C7xx
|
||||
Index: linux-2.6.23/drivers/leds/Makefile
|
||||
Index: linux-2.6.23.14/drivers/leds/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/leds/Makefile
|
||||
+++ linux-2.6.23/drivers/leds/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/leds/Makefile
|
||||
+++ linux-2.6.23.14/drivers/leds/Makefile
|
||||
@@ -5,6 +5,7 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
|
||||
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
|
||||
|
||||
|
@ -1,17 +1,17 @@
|
||||
Index: linux-2.6.23/arch/mips/pci/Makefile
|
||||
Index: linux-2.6.23.14/arch/mips/pci/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/arch/mips/pci/Makefile
|
||||
+++ linux-2.6.23/arch/mips/pci/Makefile
|
||||
--- linux-2.6.23.14.orig/arch/mips/pci/Makefile
|
||||
+++ linux-2.6.23.14/arch/mips/pci/Makefile
|
||||
@@ -46,3 +46,4 @@ obj-$(CONFIG_TOSHIBA_RBTX4938) += fixup-
|
||||
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
|
||||
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
|
||||
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
||||
+obj-$(CONFIG_PCI_ADM5120) += pci-adm5120.o
|
||||
Index: linux-2.6.23/include/linux/pci_ids.h
|
||||
Index: linux-2.6.23.14/include/linux/pci_ids.h
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/include/linux/pci_ids.h
|
||||
+++ linux-2.6.23/include/linux/pci_ids.h
|
||||
@@ -1690,6 +1690,9 @@
|
||||
--- linux-2.6.23.14.orig/include/linux/pci_ids.h
|
||||
+++ linux-2.6.23.14/include/linux/pci_ids.h
|
||||
@@ -1698,6 +1698,9 @@
|
||||
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
|
||||
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/serial/Makefile
|
||||
Index: linux-2.6.23.14/drivers/serial/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/serial/Makefile
|
||||
+++ linux-2.6.23/drivers/serial/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/serial/Makefile
|
||||
+++ linux-2.6.23.14/drivers/serial/Makefile
|
||||
@@ -21,6 +21,7 @@ obj-$(CONFIG_SERIAL_8250_EXAR_ST16C554)
|
||||
obj-$(CONFIG_SERIAL_8250_HUB6) += 8250_hub6.o
|
||||
obj-$(CONFIG_SERIAL_8250_MCA) += 8250_mca.o
|
||||
@ -10,10 +10,10 @@ Index: linux-2.6.23/drivers/serial/Makefile
|
||||
obj-$(CONFIG_SERIAL_AMBA_PL010) += amba-pl010.o
|
||||
obj-$(CONFIG_SERIAL_AMBA_PL011) += amba-pl011.o
|
||||
obj-$(CONFIG_SERIAL_CLPS711X) += clps711x.o
|
||||
Index: linux-2.6.23/include/linux/serial_core.h
|
||||
Index: linux-2.6.23.14/include/linux/serial_core.h
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/include/linux/serial_core.h
|
||||
+++ linux-2.6.23/include/linux/serial_core.h
|
||||
--- linux-2.6.23.14.orig/include/linux/serial_core.h
|
||||
+++ linux-2.6.23.14/include/linux/serial_core.h
|
||||
@@ -147,6 +147,9 @@
|
||||
#define PORT_SB1250_DUART 77
|
||||
|
||||
@ -24,10 +24,10 @@ Index: linux-2.6.23/include/linux/serial_core.h
|
||||
#ifdef __KERNEL__
|
||||
|
||||
#include <linux/compiler.h>
|
||||
Index: linux-2.6.23/drivers/serial/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/serial/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/serial/Kconfig
|
||||
+++ linux-2.6.23/drivers/serial/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/serial/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/serial/Kconfig
|
||||
@@ -280,6 +280,22 @@ config SERIAL_8250_RM9K
|
||||
|
||||
comment "Non-8250 serial port support"
|
||||
|
@ -1,10 +1,10 @@
|
||||
Index: linux-2.6.23/drivers/leds/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/leds/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/leds/Kconfig
|
||||
+++ linux-2.6.23/drivers/leds/Kconfig
|
||||
@@ -152,4 +152,12 @@ config LEDS_TRIGGER_MORSE
|
||||
tristate "LED Morse Trigger"
|
||||
depends on LEDS_TRIGGERS
|
||||
--- linux-2.6.23.14.orig/drivers/leds/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/leds/Kconfig
|
||||
@@ -165,4 +165,12 @@ config LEDS_TRIGGER_DEFAULT_ON
|
||||
This allows LEDs to be initialised in the ON state.
|
||||
If unsure, say Y.
|
||||
|
||||
+config LEDS_TRIGGER_ADM5120_SWITCH
|
||||
+ tristate "LED ADM5120 Switch Port Status Trigger"
|
||||
@ -15,12 +15,12 @@ Index: linux-2.6.23/drivers/leds/Kconfig
|
||||
+ If unsure, say N.
|
||||
+
|
||||
endif # NEW_LEDS
|
||||
Index: linux-2.6.23/drivers/leds/Makefile
|
||||
Index: linux-2.6.23.14/drivers/leds/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/leds/Makefile
|
||||
+++ linux-2.6.23/drivers/leds/Makefile
|
||||
@@ -24,3 +24,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt
|
||||
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
|
||||
--- linux-2.6.23.14.orig/drivers/leds/Makefile
|
||||
+++ linux-2.6.23.14/drivers/leds/Makefile
|
||||
@@ -26,3 +26,4 @@ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += l
|
||||
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
|
||||
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
||||
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
||||
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/mtd/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/mtd/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/Kconfig
|
||||
+++ linux-2.6.23/drivers/mtd/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/mtd/Kconfig
|
||||
@@ -160,6 +160,22 @@ config MTD_AFS_PARTS
|
||||
for your particular device. It won't happen automatically. The
|
||||
'armflash' map driver (CONFIG_MTD_ARMFLASH) does this, for example.
|
||||
@ -25,10 +25,10 @@ Index: linux-2.6.23/drivers/mtd/Kconfig
|
||||
comment "User Modules And Translation Layers"
|
||||
|
||||
config MTD_CHAR
|
||||
Index: linux-2.6.23/drivers/mtd/Makefile
|
||||
Index: linux-2.6.23.14/drivers/mtd/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/Makefile
|
||||
+++ linux-2.6.23/drivers/mtd/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/Makefile
|
||||
+++ linux-2.6.23.14/drivers/mtd/Makefile
|
||||
@@ -11,6 +11,7 @@ obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
|
||||
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
||||
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
Index: linux-2.6.23.14/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
+++ linux-2.6.23/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
+++ linux-2.6.23.14/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
@@ -47,12 +47,19 @@
|
||||
#define MANUFACTURER_AMD 0x0001
|
||||
#define MANUFACTURER_ATMEL 0x001F
|
||||
@ -74,10 +74,10 @@ Index: linux-2.6.23/drivers/mtd/chips/cfi_cmdset_0002.c
|
||||
{ 0, 0, NULL, NULL }
|
||||
};
|
||||
static struct cfi_fixup jedec_fixup_table[] = {
|
||||
Index: linux-2.6.23/drivers/mtd/chips/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/mtd/chips/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/chips/Kconfig
|
||||
+++ linux-2.6.23/drivers/mtd/chips/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/chips/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/mtd/chips/Kconfig
|
||||
@@ -196,6 +196,14 @@ config MTD_CFI_AMDSTD
|
||||
provides support for one of those command sets, used on chips
|
||||
including the AMD Am29LV320.
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/mtd/chips/jedec_probe.c
|
||||
Index: linux-2.6.23.14/drivers/mtd/chips/jedec_probe.c
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/chips/jedec_probe.c
|
||||
+++ linux-2.6.23/drivers/mtd/chips/jedec_probe.c
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/chips/jedec_probe.c
|
||||
+++ linux-2.6.23.14/drivers/mtd/chips/jedec_probe.c
|
||||
@@ -121,6 +121,10 @@
|
||||
#define UPD29F064115 0x221C
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/mtd/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/mtd/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/Kconfig
|
||||
+++ linux-2.6.23/drivers/mtd/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/mtd/Kconfig
|
||||
@@ -57,6 +57,11 @@ config MTD_ROOTFS_SPLIT
|
||||
depends on MTD_PARTITIONS
|
||||
default y
|
||||
@ -14,10 +14,10 @@ Index: linux-2.6.23/drivers/mtd/Kconfig
|
||||
config MTD_REDBOOT_PARTS
|
||||
tristate "RedBoot partition table parsing"
|
||||
depends on MTD_PARTITIONS
|
||||
Index: linux-2.6.23/drivers/mtd/Makefile
|
||||
Index: linux-2.6.23.14/drivers/mtd/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/mtd/Makefile
|
||||
+++ linux-2.6.23/drivers/mtd/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/mtd/Makefile
|
||||
+++ linux-2.6.23.14/drivers/mtd/Makefile
|
||||
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
|
||||
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
|
||||
|
||||
|
@ -1,6 +1,8 @@
|
||||
--- linux-2.6.23.9/drivers/ata/Makefile.orig 2007-11-26 18:51:43.000000000 +0100
|
||||
+++ linux-2.6.23.9/drivers/ata/Makefile 2007-12-08 18:15:07.000000000 +0100
|
||||
@@ -63,6 +63,7 @@
|
||||
Index: linux-2.6.23.14/drivers/ata/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.14.orig/drivers/ata/Makefile
|
||||
+++ linux-2.6.23.14/drivers/ata/Makefile
|
||||
@@ -63,6 +63,7 @@ obj-$(CONFIG_PATA_IXP4XX_CF) += pata_ixp
|
||||
obj-$(CONFIG_PATA_SCC) += pata_scc.o
|
||||
obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
|
||||
obj-$(CONFIG_PATA_ICSIDE) += pata_icside.o
|
||||
@ -8,9 +10,11 @@
|
||||
# Should be last but one libata driver
|
||||
obj-$(CONFIG_ATA_GENERIC) += ata_generic.o
|
||||
# Should be last libata driver
|
||||
--- linux-2.6.23.9/drivers/ata/Kconfig.orig 2007-11-26 18:51:43.000000000 +0100
|
||||
+++ linux-2.6.23.9/drivers/ata/Kconfig 2007-12-08 18:16:43.000000000 +0100
|
||||
@@ -596,4 +596,13 @@
|
||||
Index: linux-2.6.23.14/drivers/ata/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.14.orig/drivers/ata/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/ata/Kconfig
|
||||
@@ -596,4 +596,13 @@ config PATA_SCC
|
||||
|
||||
If unsure, say N.
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/arch/mips/kernel/head.S
|
||||
Index: linux-2.6.23.14/arch/mips/kernel/head.S
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/arch/mips/kernel/head.S
|
||||
+++ linux-2.6.23/arch/mips/kernel/head.S
|
||||
--- linux-2.6.23.14.orig/arch/mips/kernel/head.S
|
||||
+++ linux-2.6.23.14/arch/mips/kernel/head.S
|
||||
@@ -136,7 +136,12 @@
|
||||
/*
|
||||
* Reserved space for exception handlers.
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/serial/amba-pl010.c
|
||||
Index: linux-2.6.23.14/drivers/serial/amba-pl010.c
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/serial/amba-pl010.c
|
||||
+++ linux-2.6.23/drivers/serial/amba-pl010.c
|
||||
--- linux-2.6.23.14.orig/drivers/serial/amba-pl010.c
|
||||
+++ linux-2.6.23.14/drivers/serial/amba-pl010.c
|
||||
@@ -52,11 +52,10 @@
|
||||
|
||||
#include <asm/io.h>
|
||||
@ -264,10 +264,10 @@ Index: linux-2.6.23/drivers/serial/amba-pl010.c
|
||||
.cons = AMBA_CONSOLE,
|
||||
};
|
||||
|
||||
Index: linux-2.6.23/drivers/serial/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/serial/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/serial/Kconfig
|
||||
+++ linux-2.6.23/drivers/serial/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/serial/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/serial/Kconfig
|
||||
@@ -303,10 +303,25 @@ config SERIAL_AMBA_PL010
|
||||
help
|
||||
This selects the ARM(R) AMBA(R) PrimeCell PL010 UART. If you have
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/amba/bus.c
|
||||
Index: linux-2.6.23.14/drivers/amba/bus.c
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/amba/bus.c
|
||||
+++ linux-2.6.23/drivers/amba/bus.c
|
||||
--- linux-2.6.23.14.orig/drivers/amba/bus.c
|
||||
+++ linux-2.6.23.14/drivers/amba/bus.c
|
||||
@@ -17,6 +17,10 @@
|
||||
#include <asm/io.h>
|
||||
#include <asm/sizes.h>
|
||||
|
@ -1,8 +1,8 @@
|
||||
Index: linux-2.6.23/drivers/pci/Kconfig
|
||||
==================================================================
|
||||
--- linux-2.6.23.orig/drivers/pci/Kconfig 2007-10-09 22:31:38.000000000 +0200
|
||||
+++ linux-2.6.23/drivers/pci/Kconfig 2007-10-13 14:21:03.000000000 +0200
|
||||
@@ -31,6 +31,12 @@
|
||||
Index: linux-2.6.23.14/drivers/pci/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.14.orig/drivers/pci/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/pci/Kconfig
|
||||
@@ -31,6 +31,12 @@ config PCI_DEBUG
|
||||
|
||||
When in doubt, say N.
|
||||
|
||||
@ -15,10 +15,10 @@ Index: linux-2.6.23/drivers/pci/Kconfig
|
||||
config HT_IRQ
|
||||
bool "Interrupts on hypertransport devices"
|
||||
default y
|
||||
Index: linux-2.6.23/drivers/pci/quirks.c
|
||||
==================================================================
|
||||
--- linux-2.6.23.orig/drivers/pci/quirks.c 2007-10-09 22:31:38.000000000 +0200
|
||||
+++ linux-2.6.23/drivers/pci/quirks.c 2007-10-13 14:46:41.000000000 +0200
|
||||
Index: linux-2.6.23.14/drivers/pci/quirks.c
|
||||
===================================================================
|
||||
--- linux-2.6.23.14.orig/drivers/pci/quirks.c
|
||||
+++ linux-2.6.23.14/drivers/pci/quirks.c
|
||||
@@ -23,6 +23,7 @@
|
||||
#include <linux/acpi.h>
|
||||
#include "pci.h"
|
||||
@ -27,7 +27,7 @@ Index: linux-2.6.23/drivers/pci/quirks.c
|
||||
/* The Mellanox Tavor device gives false positive parity errors
|
||||
* Mark this device with a broken_parity_status, to allow
|
||||
* PCI scanning code to "skip" this now blacklisted device.
|
||||
@@ -1510,6 +1511,7 @@
|
||||
@@ -1510,6 +1511,7 @@ static void __devinit fixup_rev1_53c810(
|
||||
}
|
||||
}
|
||||
DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
|
||||
@ -35,7 +35,7 @@ Index: linux-2.6.23/drivers/pci/quirks.c
|
||||
|
||||
static void pci_do_fixups(struct pci_dev *dev, struct pci_fixup *f, struct pci_fixup *end)
|
||||
{
|
||||
@@ -1573,6 +1575,7 @@
|
||||
@@ -1573,6 +1575,7 @@ void pci_fixup_device(enum pci_fixup_pas
|
||||
}
|
||||
EXPORT_SYMBOL(pci_fixup_device);
|
||||
|
||||
@ -43,7 +43,7 @@ Index: linux-2.6.23/drivers/pci/quirks.c
|
||||
/* Enable 1k I/O space granularity on the Intel P64H2 */
|
||||
static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
|
||||
{
|
||||
@@ -1743,3 +1746,4 @@
|
||||
@@ -1743,3 +1746,4 @@ static void __devinit quirk_nvidia_ck804
|
||||
DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_NVIDIA, PCI_DEVICE_ID_NVIDIA_CK804_PCIE,
|
||||
quirk_nvidia_ck804_msi_ht_cap);
|
||||
#endif /* CONFIG_PCI_MSI */
|
||||
|
@ -1,8 +1,8 @@
|
||||
Index: linux-2.6.23/drivers/leds/leds-gpio.c
|
||||
Index: linux-2.6.23.14/drivers/leds/leds-gpio.c
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/leds/leds-gpio.c
|
||||
+++ linux-2.6.23/drivers/leds/leds-gpio.c
|
||||
@@ -41,13 +41,17 @@
|
||||
--- linux-2.6.23.14.orig/drivers/leds/leds-gpio.c
|
||||
+++ linux-2.6.23.14/drivers/leds/leds-gpio.c
|
||||
@@ -41,13 +41,17 @@ static void gpio_led_set(struct led_clas
|
||||
container_of(led_cdev, struct gpio_led_data, cdev);
|
||||
int level;
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
Index: linux-2.6.23/drivers/i2c/busses/Kconfig
|
||||
Index: linux-2.6.23.14/drivers/i2c/busses/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/i2c/busses/Kconfig
|
||||
+++ linux-2.6.23/drivers/i2c/busses/Kconfig
|
||||
--- linux-2.6.23.14.orig/drivers/i2c/busses/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/i2c/busses/Kconfig
|
||||
@@ -125,6 +125,17 @@ config I2C_GPIO
|
||||
This is a very simple bitbanging I2C driver utilizing the
|
||||
arch-neutral GPIO API to control the SCL and SDA lines.
|
||||
@ -20,10 +20,10 @@ Index: linux-2.6.23/drivers/i2c/busses/Kconfig
|
||||
config I2C_HYDRA
|
||||
tristate "CHRP Apple Hydra Mac I/O I2C interface"
|
||||
depends on PCI && PPC_CHRP && EXPERIMENTAL
|
||||
Index: linux-2.6.23/drivers/i2c/busses/Makefile
|
||||
Index: linux-2.6.23.14/drivers/i2c/busses/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.orig/drivers/i2c/busses/Makefile
|
||||
+++ linux-2.6.23/drivers/i2c/busses/Makefile
|
||||
--- linux-2.6.23.14.orig/drivers/i2c/busses/Makefile
|
||||
+++ linux-2.6.23.14/drivers/i2c/busses/Makefile
|
||||
@@ -13,6 +13,7 @@ obj-$(CONFIG_I2C_AU1550) += i2c-au1550.o
|
||||
obj-$(CONFIG_I2C_BLACKFIN_TWI) += i2c-bfin-twi.o
|
||||
obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Kconfig linux-2.6.23.11/drivers/char/watchdog/Kconfig
|
||||
--- linux-2.6.23.11-old/drivers/char/watchdog/Kconfig 2007-12-15 04:50:05.000000000 +0100
|
||||
+++ linux-2.6.23.11/drivers/char/watchdog/Kconfig 2007-12-26 20:17:56.000000000 +0100
|
||||
@@ -583,6 +583,18 @@
|
||||
Index: linux-2.6.23.14/drivers/char/watchdog/Kconfig
|
||||
===================================================================
|
||||
--- linux-2.6.23.14.orig/drivers/char/watchdog/Kconfig
|
||||
+++ linux-2.6.23.14/drivers/char/watchdog/Kconfig
|
||||
@@ -583,6 +583,18 @@ config SBC_EPX_C3_WATCHDOG
|
||||
|
||||
# MIPS Architecture
|
||||
|
||||
@ -20,10 +21,11 @@ diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Kconfig linux-2.6.23.11/driv
|
||||
config INDYDOG
|
||||
tristate "Indy/I2 Hardware Watchdog"
|
||||
depends on SGI_IP22
|
||||
diff -urN linux-2.6.23.11-old/drivers/char/watchdog/Makefile linux-2.6.23.11/drivers/char/watchdog/Makefile
|
||||
--- linux-2.6.23.11-old/drivers/char/watchdog/Makefile 2007-12-15 04:50:05.000000000 +0100
|
||||
+++ linux-2.6.23.11/drivers/char/watchdog/Makefile 2007-12-26 20:19:24.000000000 +0100
|
||||
@@ -87,6 +87,7 @@
|
||||
Index: linux-2.6.23.14/drivers/char/watchdog/Makefile
|
||||
===================================================================
|
||||
--- linux-2.6.23.14.orig/drivers/char/watchdog/Makefile
|
||||
+++ linux-2.6.23.14/drivers/char/watchdog/Makefile
|
||||
@@ -87,6 +87,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
|
||||
# M68KNOMMU Architecture
|
||||
|
||||
# MIPS Architecture
|
||||
|
Loading…
Reference in New Issue
Block a user