mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-10 14:21:51 +02:00
update postgresql and fix gcc 3.4 build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@748 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
99487379fe
commit
02f7e55cbd
@ -3,9 +3,9 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=postgresql
|
||||
PKG_VERSION:=7.4.6
|
||||
PKG_VERSION:=7.4.7
|
||||
PKG_RELEASE:=3
|
||||
PKG_MD5SUM:=f0ea2b372a7bdaf2613e92176ebf5e0f
|
||||
PKG_MD5SUM:=32dac2916d16287d95e0c958a75161fa
|
||||
|
||||
PKG_SOURCE_URL:=\
|
||||
ftp://ftp3.us.postgresql.org/pub/postgresql/source/v$(PKG_VERSION)/ \
|
||||
@ -22,6 +22,11 @@ IPKG_LIBPQ:=$(PACKAGE_DIR)/libpq_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
|
||||
IDIR_LIBPQ:=$(PKG_BUILD_DIR)/ipkg
|
||||
INFO_LIBPQ:=$(IPKG_STATE_DIR)/info/libpq.list
|
||||
|
||||
EXTRA_CFLAGS:=
|
||||
ifeq ($(BR2_GCC_3_4),y)
|
||||
EXTRA_CFLAGS += -fno-unit-at-a-time
|
||||
endif
|
||||
|
||||
$(DL_DIR)/$(PKG_SOURCE):
|
||||
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
|
||||
|
||||
@ -34,7 +39,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
|
||||
# ./configure advertise "--infodir", but does not support it, replaced with "--docdir"
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.cache config.status; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
|
||||
CPPFLAGS="$$CPPFLAGS -I$(STAGING_DIR)/usr/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
|
||||
./configure \
|
||||
|
@ -0,0 +1,21 @@
|
||||
diff -ruN postgresql-7.4.7-old/src/include/storage/s_lock.h postgresql-7.4.7/src/include/storage/s_lock.h
|
||||
--- postgresql-7.4.7-old/src/include/storage/s_lock.h 2004-06-15 16:09:30.000000000 +0200
|
||||
+++ postgresql-7.4.7/src/include/storage/s_lock.h 2004-06-15 16:19:02.000000000 +0200
|
||||
@@ -125,7 +125,7 @@
|
||||
__asm__ __volatile__(
|
||||
" xchg4 %0=%1,%2 \n"
|
||||
: "=r"(ret), "=m"(*lock)
|
||||
-: "r"(1), "1"(*lock)
|
||||
+: "r"(1), "m"(*lock)
|
||||
: "memory");
|
||||
|
||||
return (int) ret;
|
||||
@@ -294,7 +294,7 @@
|
||||
" tas %1 \n"
|
||||
" sne %0 \n"
|
||||
: "=d"(rv), "=m"(*lock)
|
||||
-: "1"(*lock)
|
||||
+: "m"(*lock)
|
||||
: "cc");
|
||||
|
||||
return rv;
|
@ -0,0 +1,14 @@
|
||||
diff -ruN postgresql-7.4.7-old/contrib/dbase/dbf2pg.c postgresql-7.4.7/contrib/dbase/dbf2pg.c
|
||||
--- postgresql-7.4.7-old/contrib/dbase/dbf2pg.c 2004-10-31 20:09:10.923855000 +0100
|
||||
+++ postgresql-7.4.7/contrib/dbase/dbf2pg.c 2004-10-31 20:11:24.676521696 +0100
|
||||
@@ -324,6 +324,10 @@
|
||||
case 'L':
|
||||
strcat(query, " char");
|
||||
break;
|
||||
+
|
||||
+ case 'M':
|
||||
+ strcat(query, " text");
|
||||
+ break;
|
||||
}
|
||||
}
|
||||
|
33
openwrt/package/postgresql/patches/102-debian-30libpq
Normal file
33
openwrt/package/postgresql/patches/102-debian-30libpq
Normal file
@ -0,0 +1,33 @@
|
||||
diff -ruN postgresql-7.4.7-old/src/interfaces/libpq/Makefile postgresql-7.4.7/src/interfaces/libpq/Makefile
|
||||
--- postgresql-7.4.7-old/src/interfaces/libpq/Makefile 2003-08-23 05:21:59.000000000 +0100
|
||||
+++ postgresql-7.4.7/src/interfaces/libpq/Makefile 2003-08-29 18:35:25.000000000 +0100
|
||||
@@ -32,7 +32,7 @@
|
||||
SHLIB_LINK += $(filter -lcrypt -ldes -lkrb -lcom_err -lcrypto -lk5crypto -lkrb5 -lssl -lsocket -lnsl -lresolv -lintl, $(LIBS)) $(THREAD_LIBS)
|
||||
|
||||
|
||||
-all: all-lib
|
||||
+all: all-lib libpq3-config
|
||||
|
||||
# Shared library stuff
|
||||
include $(top_srcdir)/src/Makefile.shlib
|
||||
@@ -58,6 +58,8 @@
|
||||
encnames.c wchar.c : % : $(backend_src)/utils/mb/%
|
||||
rm -f $@ && $(LN_S) $< .
|
||||
|
||||
+libpq3-config:
|
||||
+ sed -e "s|%LIBRARIES%|$(SHLIB_LINK)|" <libpq3-config.in | sed "s/-L[^ ]\+ //" >libpq3-config
|
||||
|
||||
install: all installdirs install-lib
|
||||
$(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
|
||||
@@ -73,3 +75,4 @@
|
||||
|
||||
clean distclean maintainer-clean: clean-lib
|
||||
rm -f $(OBJS) crypt.c getaddrinfo.c inet_aton.c snprintf.c strerror.c path.c thread.c dllist.c md5.c ip.c encnames.c wchar.c
|
||||
+ rm -f libpq3-config
|
||||
diff -ruN postgresql-7.4.7-old/src/interfaces/libpq/libpq3-config.in postgresql-7.4.7/src/interfaces/libpq/libpq3-config.in
|
||||
--- postgresql-7.4.7-old/src/interfaces/libpq/libpq3-config.in 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ postgresql-7.4.7/src/interfaces/libpq/libpq3-config.in 2003-08-29 18:34:25.000000000 +0100
|
||||
@@ -0,0 +1,3 @@
|
||||
+#!/bin/bash
|
||||
+
|
||||
+echo %LIBRARIES%
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user