1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-27 16:43:09 +02:00

package/mac80211: fix a possible NULL pointer dereference in rt2x00

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30586 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2012-02-16 17:14:34 +00:00
parent a0ef5265a1
commit 0853b66205
2 changed files with 13 additions and 1 deletions

View File

@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2012-02-06
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_MD5SUM:=fae71c35ee3f3de6329f2db7aed6d265

View File

@ -0,0 +1,12 @@
--- a/drivers/net/wireless/rt2x00/rt2x00dev.c
+++ b/drivers/net/wireless/rt2x00/rt2x00dev.c
@@ -1224,7 +1224,8 @@ void rt2x00lib_remove_dev(struct rt2x00_
cancel_work_sync(&rt2x00dev->rxdone_work);
cancel_work_sync(&rt2x00dev->txdone_work);
}
- destroy_workqueue(rt2x00dev->workqueue);
+ if (rt2x00dev->workqueue)
+ destroy_workqueue(rt2x00dev->workqueue);
/*
* Free the tx status fifo.