1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-23 23:16:16 +02:00

kernel: when disabling common quirks, disable them in the usb subsystem as well - bios handover is useless for most platforms

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25768 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2011-02-27 19:52:43 +00:00
parent 33bee11d7c
commit 09a75bcf9c
2 changed files with 24 additions and 0 deletions

View File

@ -0,0 +1,12 @@
--- a/drivers/usb/host/Makefile
+++ b/drivers/usb/host/Makefile
@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
obj-$(CONFIG_USB_WHCI_HCD) += whci/
+ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
obj-$(CONFIG_PCI) += pci-quirks.o
+endif
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o

View File

@ -0,0 +1,12 @@
--- a/drivers/usb/host/Makefile
+++ b/drivers/usb/host/Makefile
@@ -16,7 +16,9 @@ xhci-hcd-y += xhci-ring.o xhci-hub.o xhc
obj-$(CONFIG_USB_WHCI_HCD) += whci/
+ifndef CONFIG_PCI_DISABLE_COMMON_QUIRKS
obj-$(CONFIG_PCI) += pci-quirks.o
+endif
obj-$(CONFIG_USB_EHCI_HCD) += ehci-hcd.o
obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o