1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 19:43:16 +03:00

[uboot-lantiq]

* add some compile flags


git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26025 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2011-03-11 08:22:47 +00:00
parent 1bcca9e4df
commit 0ae5a76a91

View File

@ -1,6 +1,6 @@
--- a/cpu/mips/config.mk
+++ b/cpu/mips/config.mk
@@ -23,16 +23,18 @@
@@ -23,17 +23,19 @@
v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
MIPSFLAGS:=$(shell \
if [ "$v" -lt "14" ]; then \
@ -19,5 +19,7 @@
endif
+endif
MIPSFLAGS += $(ENDIANNESS)
-MIPSFLAGS += $(ENDIANNESS)
+MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
PLATFORM_CPPFLAGS += $(MIPSFLAGS)