mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-25 00:57:31 +02:00
Merge branch 'xburst' of git@projects.qi-hardware.com:openwrt-xburst into xburst
This commit is contained in:
commit
0c0247d223
@ -137,6 +137,7 @@ CONFIG_HW_CONSOLE=y
|
||||
CONFIG_INET_DIAG=y
|
||||
CONFIG_INET_TCP_DIAG=y
|
||||
CONFIG_INPUT=y
|
||||
CONFIG_INPUT_EVDEV=y
|
||||
# CONFIG_INPUT_GPIO_BUTTONS is not set
|
||||
CONFIG_INPUT_KEYBOARD=y
|
||||
# CONFIG_INPUT_YEALINK is not set
|
||||
@ -150,6 +151,7 @@ CONFIG_IP_PNP_DHCP=y
|
||||
# CONFIG_IP_PNP_RARP is not set
|
||||
CONFIG_IRQ_CPU=y
|
||||
CONFIG_JBD=y
|
||||
# CONFIG_JFFS2_FS is not set
|
||||
CONFIG_JZ4740_ADC=y
|
||||
CONFIG_JZ4740_QI_LB60=y
|
||||
CONFIG_JZRISC=y
|
||||
@ -163,7 +165,6 @@ CONFIG_KEYBOARD_MATRIX=y
|
||||
# CONFIG_KEYBOARD_STOWAWAY is not set
|
||||
# CONFIG_KEYBOARD_SUNKBD is not set
|
||||
# CONFIG_KEYBOARD_XTKBD is not set
|
||||
CONFIG_LBDAF=y
|
||||
CONFIG_LCD_CLASS_DEVICE=y
|
||||
CONFIG_LCD_GPM940B0=y
|
||||
# CONFIG_LCD_ILI9320 is not set
|
||||
@ -192,6 +193,7 @@ CONFIG_MACH_JZ=y
|
||||
# CONFIG_MACH_TX49XX is not set
|
||||
# CONFIG_MACH_VR41XX is not set
|
||||
# CONFIG_MIKROTIK_RB532 is not set
|
||||
# CONFIG_MINI_FO is not set
|
||||
CONFIG_MIPS=y
|
||||
# CONFIG_MIPS_COBALT is not set
|
||||
# CONFIG_MIPS_FPU_EMU is not set
|
||||
@ -225,6 +227,7 @@ CONFIG_MTD_UBI_WL_THRESHOLD=4096
|
||||
# CONFIG_NET_SCHED is not set
|
||||
# CONFIG_NEW_LEDS is not set
|
||||
CONFIG_NLS=y
|
||||
CONFIG_NLS_CODEPAGE_437=y
|
||||
# CONFIG_NO_IOPORT is not set
|
||||
# CONFIG_NXP_STB220 is not set
|
||||
# CONFIG_NXP_STB225 is not set
|
||||
@ -252,7 +255,7 @@ CONFIG_SCHED_OMIT_FRAME_POINTER=y
|
||||
# CONFIG_SCSI_DMA is not set
|
||||
CONFIG_SDIO_UART=y
|
||||
CONFIG_SECCOMP=y
|
||||
# CONFIG_SERIAL_8250_EXTENDED is not set
|
||||
# CONFIG_SERIAL_8250 is not set
|
||||
CONFIG_SERIO=y
|
||||
# CONFIG_SERIO_I8042 is not set
|
||||
CONFIG_SERIO_LIBPS2=y
|
||||
@ -296,6 +299,7 @@ CONFIG_SPI_BITBANG=y
|
||||
CONFIG_SPI_GPIO=y
|
||||
CONFIG_SPI_MASTER=y
|
||||
# CONFIG_SPI_SPIDEV is not set
|
||||
# CONFIG_SQUASHFS is not set
|
||||
CONFIG_SUSPEND=y
|
||||
CONFIG_SUSPEND_FREEZER=y
|
||||
# CONFIG_SYN_COOKIES is not set
|
||||
@ -308,7 +312,7 @@ CONFIG_SYS_SUPPORTS_LITTLE_ENDIAN=y
|
||||
CONFIG_TCP_CONG_CUBIC=y
|
||||
CONFIG_TRAD_SIGNALS=y
|
||||
CONFIG_UBIFS_FS=y
|
||||
# CONFIG_UBIFS_FS_ADVANCED_COMPR is not set
|
||||
CONFIG_UBIFS_FS_ADVANCED_COMPR=y
|
||||
# CONFIG_UBIFS_FS_DEBUG is not set
|
||||
CONFIG_UBIFS_FS_LZO=y
|
||||
# CONFIG_UBIFS_FS_XATTR is not set
|
||||
|
@ -7,8 +7,8 @@
|
||||
* Author: Xiangfu Liu <xiangfu@qi-hardware.com>
|
||||
*
|
||||
* This program is free software; you can redistribute it and/or modify
|
||||
* it under the terms of the GNU General Public License version 3 as
|
||||
* published by the Free Software Foundation.
|
||||
* it under the terms of the GNU General Public License version 2 or later
|
||||
* as published by the Free Software Foundation.
|
||||
*/
|
||||
|
||||
#include <linux/kernel.h>
|
||||
|
@ -1,13 +1,13 @@
|
||||
From 0e135685e7045f606feb6ffc8f2b159e87fcd389 Mon Sep 17 00:00:00 2001
|
||||
From 23f08521fd9f997876d5e90354b9ad957bb4e982 Mon Sep 17 00:00:00 2001
|
||||
From: Xiangfu Liu <xiangfu@qi-hardware.com>
|
||||
Date: Fri, 30 Oct 2009 14:49:02 +0800
|
||||
Subject: [PATCH] add new file
|
||||
Date: Wed, 18 Nov 2009 23:23:56 +0800
|
||||
Subject: [PATCH 1/2] add new file
|
||||
|
||||
---
|
||||
board/qi_lb60/Makefile | 38 +
|
||||
board/qi_lb60/config.mk | 31 +
|
||||
board/qi_lb60/flash.c | 50 +
|
||||
board/qi_lb60/qi_lb60.c | 103 +
|
||||
board/qi_lb60/qi_lb60.c | 105 +
|
||||
board/qi_lb60/u-boot-nand.lds | 63 +
|
||||
board/qi_lb60/u-boot.lds | 63 +
|
||||
cpu/mips/jz4740.c | 574 +++++
|
||||
@ -33,7 +33,7 @@ Subject: [PATCH] add new file
|
||||
nand_spl/board/qi_lb60/config.mk | 34 +
|
||||
nand_spl/board/qi_lb60/u-boot.lds | 63 +
|
||||
nand_spl/nand_boot_jz4740.c | 456 ++++
|
||||
29 files changed, 13573 insertions(+), 0 deletions(-)
|
||||
29 files changed, 13575 insertions(+), 0 deletions(-)
|
||||
create mode 100644 board/qi_lb60/Makefile
|
||||
create mode 100644 board/qi_lb60/config.mk
|
||||
create mode 100644 board/qi_lb60/flash.c
|
||||
@ -203,7 +203,7 @@ index 0000000..891c604
|
||||
+}
|
||||
diff --git a/board/qi_lb60/qi_lb60.c b/board/qi_lb60/qi_lb60.c
|
||||
new file mode 100644
|
||||
index 0000000..572d22b
|
||||
index 0000000..d13f2ab
|
||||
--- /dev/null
|
||||
+++ b/board/qi_lb60/qi_lb60.c
|
||||
@@ -0,0 +1,105 @@
|
||||
@ -12915,7 +12915,7 @@ index 0000000..2840bc0
|
||||
+#endif /* __JZ4740_H__ */
|
||||
diff --git a/include/configs/qi_lb60.h b/include/configs/qi_lb60.h
|
||||
new file mode 100644
|
||||
index 0000000..e78d17f
|
||||
index 0000000..02af607
|
||||
--- /dev/null
|
||||
+++ b/include/configs/qi_lb60.h
|
||||
@@ -0,0 +1,213 @@
|
||||
@ -12965,8 +12965,8 @@ index 0000000..e78d17f
|
||||
+#define CONFIG_BOOTP_MASK (CONFIG_BOOTP_DEFAUL)
|
||||
+#define CONFIG_BOOTDELAY 0
|
||||
+#define CONFIG_BOOTFILE "uImage" /* file to load */
|
||||
+#define CONFIG_BOOTARGS "mem=32M console=ttyS0,57600n8 rootfstype=jffs2 root=/dev/mtdblock2 rw rootwait"
|
||||
+#define CONFIG_BOOTCOMMAND "nand read 0x80600000 0x400000 0x300000;bootm"
|
||||
+#define CONFIG_BOOTARGS "mem=32M console=ttyS0,57600n8 ubi.mtd=2 rootfstype=ubifs root=ubi0:rootfs rw rootwait"
|
||||
+#define CONFIG_BOOTCOMMAND "nand read 0x80600000 0x400000 0x200000;bootm"
|
||||
+
|
||||
+/*
|
||||
+ * Command line configuration.
|
||||
@ -13814,5 +13814,5 @@ index 0000000..924a47a
|
||||
+ (*uboot)();
|
||||
+}
|
||||
--
|
||||
1.6.0.4
|
||||
1.6.3.3
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
From 7d8029d27d53b04b223a638de4fc726f6c68359f Mon Sep 17 00:00:00 2001
|
||||
From 7f32a7a2ec1cf7472684869a5cec40013134c92b Mon Sep 17 00:00:00 2001
|
||||
From: Xiangfu Liu <xiangfu@qi-hardware.com>
|
||||
Date: Wed, 21 Oct 2009 11:02:22 +0800
|
||||
Subject: [PATCH] add qi_lb60 support
|
||||
Date: Wed, 18 Nov 2009 23:24:14 +0800
|
||||
Subject: [PATCH 2/2] add-xburst-support
|
||||
|
||||
---
|
||||
Makefile | 10 +
|
||||
@ -1585,5 +1585,5 @@ index 07e356d..4654bf4 100644
|
||||
+
|
||||
+#endif /* !CONFIG_JzRISC */
|
||||
--
|
||||
1.6.0.4
|
||||
1.6.3.3
|
||||
|
||||
|
@ -0,0 +1,30 @@
|
||||
From 6901dd7d88680eb08b9bd3000244aa8003d0de9f Mon Sep 17 00:00:00 2001
|
||||
From: Xiangfu Liu <xiangfu@qi-hardware.com>
|
||||
Date: Fri, 20 Nov 2009 23:29:31 +0800
|
||||
Subject: [PATCH] disable init gpio as uart0
|
||||
|
||||
---
|
||||
board/qi_lb60/qi_lb60.c | 6 ++++--
|
||||
1 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/board/qi_lb60/qi_lb60.c b/board/qi_lb60/qi_lb60.c
|
||||
index d13f2ab..d87619c 100644
|
||||
--- a/board/qi_lb60/qi_lb60.c
|
||||
+++ b/board/qi_lb60/qi_lb60.c
|
||||
@@ -25,9 +25,11 @@ static void gpio_init(void)
|
||||
__gpio_as_sdram_32bit();
|
||||
|
||||
/*
|
||||
- * Initialize UART0 pins
|
||||
+ * Initialize UART0 pins, in Ben NanoNote uart0 and keyin8 use the
|
||||
+ * same gpio, init the gpio as uart0 cause a keyboard bug. so for
|
||||
+ * end user we disable the uart0
|
||||
*/
|
||||
- __gpio_as_uart0();
|
||||
+ /* __gpio_as_uart0(); */
|
||||
|
||||
/*
|
||||
* Initialize LCD pins
|
||||
--
|
||||
1.6.3.3
|
||||
|
Loading…
Reference in New Issue
Block a user