1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-02 21:09:29 +03:00

remove lua's dependency on libreadline and libncurses

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10817 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2008-04-13 14:34:36 +00:00
parent 5c1eb4b4e9
commit 124c9d9c48
2 changed files with 54 additions and 1 deletions

View File

@ -53,7 +53,7 @@ endef
define Package/lua
$(call Package/lua/Default)
DEPENDS:=+liblua +libreadline +libncurses
DEPENDS:=+liblua
TITLE+= (interpreter)
endef

View File

@ -0,0 +1,53 @@
Index: lua-5.1.3/src/luaconf.h
===================================================================
--- lua-5.1.3.orig/src/luaconf.h 2008-04-13 16:18:00.338123105 +0200
+++ lua-5.1.3/src/luaconf.h 2008-04-13 16:18:14.110907972 +0200
@@ -36,7 +36,6 @@
#if defined(LUA_USE_LINUX)
#define LUA_USE_POSIX
#define LUA_USE_DLOPEN /* needs an extra library: -ldl */
-#define LUA_USE_READLINE /* needs some extra libraries */
#endif
#if defined(LUA_USE_MACOSX)
Index: lua-5.1.3/src/Makefile
===================================================================
--- lua-5.1.3.orig/src/Makefile 2008-04-13 16:18:18.695169214 +0200
+++ lua-5.1.3/src/Makefile 2008-04-13 16:24:41.036957630 +0200
@@ -17,6 +17,7 @@
MYCFLAGS=
MYLDFLAGS=
MYLIBS=
+# USE_READLINE=1
# == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
@@ -83,7 +84,7 @@
@echo "MYLIBS = $(MYLIBS)"
# convenience targets for popular platforms
-
+RFLAG=$(if $(USE_READLINE),-DLUA_USE_READLINE)
none:
@echo "Please choose a platform:"
@echo " $(PLATS)"
@@ -98,16 +99,16 @@
$(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
freebsd:
- $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX" MYLIBS="-Wl,-E -lreadline"
+ $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E$(if $(USE_READLINE), -lreadline)"
generic:
$(MAKE) all MYCFLAGS=
linux:
- $(MAKE) all MYCFLAGS+=-DLUA_USE_LINUX MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses"
+ $(MAKE) all MYCFLAGS+="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E -ldl $(if $(USE_READLINE), -lreadline -lhistory -lncurses)"
macosx:
- $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-lreadline"
+ $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX $(if $(USE_READLINE), MYLIBS="-lreadline")
# use this on Mac OS X 10.3-
# $(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX