mirror of
git://projects.qi-hardware.com/openwrt-xburst.git
synced 2024-11-23 21:00:37 +02:00
tools/ipkg-utils: calculate installed size from embedded data.tar.gz, makes opkg space checking more precise
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25021 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
89a10d913b
commit
14c41ae66a
@ -12,7 +12,6 @@ PKG_VERSION:=1.7
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://handhelds.org/packages/ipkg-utils/
|
||||
PKG_MD5SUM:=da3e3ef772973d7370a6ac95f0fef9b8
|
||||
PKG_CAT:=zcat
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
|
14
tools/ipkg-utils/patches/180-add_installed_size.patch
Normal file
14
tools/ipkg-utils/patches/180-add_installed_size.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- a/ipkg-build
|
||||
+++ b/ipkg-build
|
||||
@@ -250,6 +250,11 @@ mkdir $tmp_dir
|
||||
|
||||
echo $CONTROL > $tmp_dir/tarX
|
||||
( cd $pkg_dir && $TAR $ogargs -X $tmp_dir/tarX -czf $tmp_dir/data.tar.gz . )
|
||||
+
|
||||
+installed_size=`du -b $tmp_dir/data.tar.gz | cut -f1`
|
||||
+sed -i -e "s/^Installed-Size: .*/Installed-Size: $installed_size/" \
|
||||
+ $pkg_dir/$CONTROL/control
|
||||
+
|
||||
( cd $pkg_dir/$CONTROL && $TAR $ogargs -czf $tmp_dir/control.tar.gz . )
|
||||
rm $tmp_dir/tarX
|
||||
|
Loading…
Reference in New Issue
Block a user