1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-11-10 11:16:14 +02:00

rename wl.o wireless interface from ethX to wl0

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3732 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2006-05-06 02:34:35 +00:00
parent c19c89c25d
commit 18d730efee
3 changed files with 12 additions and 5 deletions

View File

@ -16339,7 +16339,7 @@ diff -urN linux.old/drivers/net/wireless/Config.in linux.dev/drivers/net/wireles
diff -urN linux.old/drivers/net/wl/Makefile linux.dev/drivers/net/wl/Makefile
--- linux.old/drivers/net/wl/Makefile 1970-01-01 01:00:00.000000000 +0100
+++ linux.dev/drivers/net/wl/Makefile 2006-04-28 01:33:52.000000000 +0200
@@ -0,0 +1,23 @@
@@ -0,0 +1,26 @@
+#
+# Makefile for the Broadcom wl driver
+#
@ -16357,11 +16357,14 @@ diff -urN linux.old/drivers/net/wl/Makefile linux.dev/drivers/net/wl/Makefile
+
+O_TARGET := wl.o
+
+obj-y := wl_apsta.o
+obj-y := wl_mod.o
+obj-y += bcmutils.o hnddma.o linux_osl.o
+
+obj-m := $(O_TARGET)
+
+wl_mod.o: wl_apsta.o
+ sed -e 's,eth%d,wl%d\x00,g' < $< > $@
+
+include $(TOPDIR)/Rules.make
diff -urN linux.old/drivers/net/wl/bcmip.h linux.dev/drivers/net/wl/bcmip.h
--- linux.old/drivers/net/wl/bcmip.h 1970-01-01 01:00:00.000000000 +0100

View File

@ -1,5 +1,5 @@
#!/bin/sh
setup_eth()
setup_wl()
{
[ -f /proc/net/wl0 ] && {
lsmod | grep wlcompat >&- || insmod wlcompat
@ -7,6 +7,9 @@ setup_eth()
iwconfig "$INTERFACE" 2>&- | grep -v 'no wireless' >&- && {
/sbin/wifi
}
}
setup_eth()
{
[ -d /proc/switch ] || {
insmod switch-core
insmod switch-robo || insmod switch-adm
@ -30,6 +33,7 @@ do_register()
{
case "${INTERFACE%%[0-9]*}" in
eth) setup_eth;;
wl) setup_wl;;
esac
}

View File

@ -980,13 +980,13 @@ static int new_ioctl(struct net_device *dev, struct ifreq *ifr, int cmd) {
static int __init wlcompat_init()
{
int found = 0, i;
char *devname = "eth0";
char devname[4] = "wl0";
bss_force = 0;
while (!found && (dev = dev_get_by_name(devname))) {
if ((dev->wireless_handlers == NULL) && ((wl_ioctl(dev, WLC_GET_MAGIC, &i, sizeof(i)) == 0) && i == WLC_IOCTL_MAGIC))
found = 1;
devname[3]++;
devname[2]++;
}
if (!found) {