1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-08-20 00:09:01 +03:00

ramips: add Kbuild patch for the rt288x pci code, and fix invalid header file paths

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17860 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2009-10-05 09:06:10 +00:00
parent a09d2cc27a
commit 19a1c70613
3 changed files with 13 additions and 4 deletions

View File

@ -7,8 +7,9 @@
#include <asm/io.h>
#include <linux/init.h>
#include <linux/mod_devicetable.h>
#include <asm/mach-rt288x/rt288x.h>
#include <asm/mach-rt288x/rt288x_pci.h>
#include <asm/mach-ralink/rt288x.h>
#include <asm/mach-ralink/rt288x_pci.h>
#ifdef CONFIG_PCI

View File

@ -5,11 +5,12 @@
#include <linux/version.h>
#include <asm/pci.h>
#include <asm/io.h>
#include <asm/mach-rt288x/rt288x.h>
#include <asm/mach-rt288x/rt288x_pci.h>
#include <linux/init.h>
#include <linux/mod_devicetable.h>
#include <asm/mach-ralink/rt288x.h>
#include <asm/mach-ralink/rt288x_pci.h>
#ifdef CONFIG_PCI
extern int pci_config_read(struct pci_bus *bus, unsigned int devfn, int where, int size, u32 *val);

View File

@ -0,0 +1,7 @@
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
@@ -52,3 +52,4 @@
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
+obj-$(CONFIG_SOC_RT288X) += pci-rt288x.o ops-rt288x.o