1
0
mirror of git://projects.qi-hardware.com/openwrt-xburst.git synced 2024-07-01 00:20:44 +03:00

gdb: update to version 7.5

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33998 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2012-10-29 19:25:26 +00:00
parent cee772c8a3
commit 1a6b5dab71
2 changed files with 8 additions and 17 deletions

View File

@ -8,15 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gdb
PKG_VERSION:=6.8a
PKG_RELEASE:=4
PKG_VERSION:=7.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNU/gdb
PKG_MD5SUM:=da20d043e6729f74b909bd507bcae5c9
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-6.8
PKG_MD5SUM:=24a6779a9fe0260667710de1b082ef61
PKG_BUILD_PARALLEL:=0
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -63,6 +63,9 @@ define Build/Compile
DESTDIR="$(PKG_INSTALL_DIR)" \
CPPFLAGS="$(TARGET_CPPFLAGS)" \
all
endef
define Build/Install
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
CPPFLAGS="$(TARGET_CPPFLAGS)" \

View File

@ -1,12 +0,0 @@
diff -urN gdb-6.8/gdb/linux-nat.h gdb-6.8a.new/gdb/linux-nat.h
--- gdb-6.8/gdb/linux-nat.h 2008-01-23 12:26:28.000000000 +0100
+++ gdb-6.8a.new/gdb/linux-nat.h 2012-09-19 16:37:10.468916796 +0200
@@ -60,7 +60,7 @@
/* Non-zero si_signo if this LWP stopped with a trap. si_addr may
be the address of a hardware watchpoint. */
- struct siginfo siginfo;
+ siginfo_t siginfo;
/* If WAITSTATUS->KIND != TARGET_WAITKIND_SPURIOUS, the waitstatus
for this LWP's last event. This may correspond to STATUS above,